[rt-users] Component path given to Interp->load must be absolute

Brad S Konia brad at hostland.com
Thu Oct 29 22:01:22 EDT 2015


I installed RT 4.2.12 on a Litespeed web server and everything seems to be working, except it’s not rendering any of the images, CSS or JS. I see tons of messages like this in my error log:

Oct 29 18:27:28 web1 RT: [2202] Component path given to Interp->load must be absolute (was given static/images/bpslogo.png)#012Stack:#012  [/usr/local/share/perl5/HTML/Mason/Request.pm:249]#012  [/usr/local/share/perl5/HTML/Mason/Request.pm:212]#012  [/opt/rt4/sbin/../lib/RT/Interface/Web/Request.pm:61]#012  [/usr/local/share/perl5/Class/Container.pm:275]#012  [/usr/local/share/perl5/Class/Container.pm:353]#012  [/usr/local/share/perl5/HTML/Mason/Interp.pm:348]#012  [/usr/local/share/perl5/HTML/Mason/Interp.pm:342]#012  [/usr/local/share/perl5/HTML/Mason/PSGIHandler.pm:59]#012  [/usr/local/share/perl5/HTML/Mason/PSGIHandler/Streamy.pm:52]#012  [/opt/rt4/sbin/../lib/RT/Interface/Web/Handler.pm:310]#012  [/usr/local/share/perl5/Plack/Util.pm:339]#012  [/usr/local/share/perl5/Plack/Handler/FCGI.pm:145]#012  [/usr/local/share/perl5/Plack/Loader.pm:84]#012  [/usr/local/share/perl5/Plack/Runner.pm:277]#012  [/opt/rt4/sbin/../lib/RT/PlackRunner.pm:141]#012  [/opt/rt4/sbin/rt-server.fcgi:162]

From the above error message, it seems the script wants an absolute path. Upon viewing the HTML source code, I see the path is in fact absolute: src="/static/images/bpslogo.png”

This led me to believe that something is causing the script to drop the leading slash. To test this theory, I tried accessing the image via the following URL:

https://rt.hostland.com//static/images/bpslogo.png (note the extra leading slash)

and it worked!

I’m sure this issue is due to some incompatibility between the Litespeed configuration and the standard Apache configuration documented in the manual, but I’m not sure how to fix this. I tried working around it by playing around with the $WebDomain and $WebPath variables to force an extra leading slash and the results were fairly disastrous. I’m wondering if anyone else has gotten this working on Litespeed or if anyone can offer any suggestions on how I might proceed.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20151029/ea6acd22/attachment.html>


More information about the rt-users mailing list