[rt-users] Full text indexing error with MySQL

Omen Wild omen at ucdavis.edu
Fri Aug 26 12:14:41 EDT 2016

Quoting Alex Vandiver <alex at chmrr.net> on Thu, Aug 25 22:39:
> On Thu, 25 Aug 2016 20:49:48 -0700
> Omen Wild <omen at ucdavis.edu> wrote:
> > I activated the full text indexing under Ubuntu 16.04 (request-tracker4
> > 4.2.12-5) and (mysql-server 5.7.13-0ubuntu0.16.04.2). Both the initial
> > indexing and subsequent calls to rt-fulltext-indexer have the same error:
> > 
> > ----- Begin quote -----
> > [3159] [Fri Aug 26 03:03:08 2016] [warning]: DBD::mysql::st execute failed: MySQL server has gone away
> That error is almost always that RT tried to do an insert or update
> of data larger that the MySQL server's max_allowed_packet.  Try
> increasing that setting, restarting MySQL, and indexing again.

And indeed that was the problem. Bumped it from 16M to 64M and all is
well. And now that I check the MySQL error logs I see it complaining
there. Thanks for the tip!

Omen Wild
Systems Administrator
Metro Cluster

More information about the rt-users mailing list