[rt-users] AH00130: File does not exist: /opt/rt4/sbin/rt-server.fcgi/

Abilash Praveen [Consign IT Private Limited] abilash at consignit.in
Thu Jan 7 13:04:28 EST 2016


I fixed this by fixing the following. I hope this helps someone.

#1 mod_fcgid was compiled but not loaded in Apache
#2 suexec reported wrong permissions for rt-server.fcgi
#3 RT reported wrong permissions for RT_Config.pm

On Thu, Jan 7, 2016 at 5:49 PM, Abilash Praveen [Consign IT Private
Limited] <abilash at consignit.in> wrote:

> Hello,
>
> This is a new installation of RT 4.2.12. I'm using mod_fcgid and followed
> instructions from
> https://www.bestpractical.com/docs/rt/4.2/web_deployment.html#mod_fcgid
>
> RT permissions are:
> drwxr-xr-x. 10 root   root   4.0K Jan  7 13:39 ./
> drwxr-xr-x. 14 root   root   4.0K Jan  7 13:39 ../
> drwxr-xr-x.  2 root   root   4.0K Jan  7 13:39 bin/
> drwxr-xr-x.  7 root   root   4.0K Jan  7 13:39 docs/
> drwxr-xr-x.  3 root   nobody 4.0K Jan  7 17:35 etc/
> drwxr-xr-x.  3 root   bin    4.0K Jan  7 13:39 lib/
> drwxr-xr-x.  9 root   root   4.0K Jan  7 14:03 local/
> drwxr-xr-x.  2 root   root   4.0K Jan  7 13:39 sbin/
> drwxr-xr-x.  6 root   root   4.0K Jan  7 13:39 share/
> drwxr-xr-x.  5 nobody nobody 4.0K Jan  7 13:39 var/
>
> My virtualhost config has the following:
>         ### Optional apache logs for RT
>         # Ensure that your log rotation scripts know about these files
>          ErrorLog /opt/rt4/var/log/apache2.error
>         # TransferLog /opt/rt4/var/log/apache2.access
>          LogLevel debug
>
>         AddDefaultCharset UTF-8
>
>         ScriptAlias / /opt/rt4/sbin/rt-server.fcgi/
>
>         DocumentRoot "/opt/rt4/share/html"
>         <Location />
>             #<IfVersion >= 2.4> # For Apache 2.4
>                 Require all granted
>             #</IfVersion>
>             #<IfVersion < 2.4>  # For Apache 2.2
>             #    Order allow,deny
>             #    Allow from all
>             #</IfVersion>
>
>             Options +ExecCGI
>             AddHandler fcgid-script fcgi
>         </Location>
>
> Apache's error log has no information. Access log just shows a 404.
>
> RT's log shows the following:
> (var/log/apache2.error)
> (Server version: Apache/2.4.18 (Unix))
>
> [Thu Jan 07 17:46:01.470791 2016] [ssl:info] [pid 20705] [client
> 117.218.246.102:29813] AH01964: Connection to child 13 established
> (server rt.consignweb.com:443)
> [Thu Jan 07 17:46:01.471199 2016] [ssl:debug] [pid 20705]
> ssl_engine_kernel.c(2096): [client 117.218.246.102:29813] AH02043: SSL
> virtual host for servername rt.consignweb.com found
> [Thu Jan 07 17:46:01.471234 2016] [ssl:debug] [pid 20705]
> ssl_util_stapling.c(754): AH01951: stapling_cb: OCSP Stapling callback
> called
> [Thu Jan 07 17:46:01.471282 2016] [ssl:debug] [pid 20705]
> ssl_util_stapling.c(762): AH01952: stapling_cb: retrieved cached
> certificate data
> [Thu Jan 07 17:46:01.471303 2016] [socache_shmcb:debug] [pid 20705]
> mod_socache_shmcb.c(528): AH00835: socache_shmcb_retrieve (0xa6 -> subcache
> 6)
> [Thu Jan 07 17:46:01.471313 2016] [socache_shmcb:debug] [pid 20705]
> mod_socache_shmcb.c(880): AH00849: match at idx=0, data=0
> [Thu Jan 07 17:46:01.471318 2016] [socache_shmcb:debug] [pid 20705]
> mod_socache_shmcb.c(538): AH00836: leaving socache_shmcb_retrieve
> successfully
> [Thu Jan 07 17:46:01.471333 2016] [ssl:debug] [pid 20705]
> ssl_util_stapling.c(314): AH01933: stapling_get_cached_response: cache hit
> [Thu Jan 07 17:46:01.471338 2016] [ssl:debug] [pid 20705]
> ssl_util_stapling.c(697): AH01953: stapling_cb: retrieved cached response
> [Thu Jan 07 17:46:01.471389 2016] [ssl:debug] [pid 20705]
> ssl_util_stapling.c(813): AH01956: stapling_cb: setting response
> [Thu Jan 07 17:46:01.477482 2016] [ssl:info] [pid 20704] [client
> 117.218.246.102:29814] AH01964: Connection to child 14 established
> (server rt.consignweb.com:443)
> [Thu Jan 07 17:46:01.477594 2016] [ssl:debug] [pid 20704]
> ssl_engine_kernel.c(2096): [client 117.218.246.102:29814] AH02043: SSL
> virtual host for servername rt.consignweb.com found
> [Thu Jan 07 17:46:01.477611 2016] [ssl:debug] [pid 20704]
> ssl_util_stapling.c(754): AH01951: stapling_cb: OCSP Stapling callback
> called
> [Thu Jan 07 17:46:01.477628 2016] [ssl:debug] [pid 20704]
> ssl_util_stapling.c(762): AH01952: stapling_cb: retrieved cached
> certificate data
> [Thu Jan 07 17:46:01.477641 2016] [socache_shmcb:debug] [pid 20704]
> mod_socache_shmcb.c(528): AH00835: socache_shmcb_retrieve (0xa6 -> subcache
> 6)
> [Thu Jan 07 17:46:01.477649 2016] [socache_shmcb:debug] [pid 20704]
> mod_socache_shmcb.c(880): AH00849: match at idx=0, data=0
> [Thu Jan 07 17:46:01.477653 2016] [socache_shmcb:debug] [pid 20704]
> mod_socache_shmcb.c(538): AH00836: leaving socache_shmcb_retrieve
> successfully
> [Thu Jan 07 17:46:01.477664 2016] [ssl:debug] [pid 20704]
> ssl_util_stapling.c(314): AH01933: stapling_get_cached_response: cache hit
> [Thu Jan 07 17:46:01.477669 2016] [ssl:debug] [pid 20704]
> ssl_util_stapling.c(697): AH01953: stapling_cb: retrieved cached response
> [Thu Jan 07 17:46:01.477700 2016] [ssl:debug] [pid 20704]
> ssl_util_stapling.c(813): AH01956: stapling_cb: setting response
> [Thu Jan 07 17:46:01.544941 2016] [ssl:debug] [pid 20705]
> ssl_engine_kernel.c(2023): [client 117.218.246.102:29813] AH02041:
> Protocol: TLSv1.2, Cipher: ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
> [Thu Jan 07 17:46:01.551837 2016] [ssl:debug] [pid 20704]
> ssl_engine_kernel.c(2023): [client 117.218.246.102:29814] AH02041:
> Protocol: TLSv1.2, Cipher: ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
> [Thu Jan 07 17:46:01.660744 2016] [ssl:debug] [pid 20705]
> ssl_engine_kernel.c(354): [client 117.218.246.102:29813] AH02034: Initial
> (No.1) HTTPS request received for child 13 (server rt.consignweb.com:443)
> [Thu Jan 07 17:46:01.661552 2016] [authz_core:debug] [pid 20705]
> mod_authz_core.c(809): [client 117.218.246.102:29813] AH01626:
> authorization result of Require all granted: granted
> [Thu Jan 07 17:46:01.661566 2016] [authz_core:debug] [pid 20705]
> mod_authz_core.c(809): [client 117.218.246.102:29813] AH01626:
> authorization result of <RequireAny>: granted
> [Thu Jan 07 17:46:01.661938 2016] [core:info] [pid 20705] [client
> 117.218.246.102:29813] AH00130: File does not exist:
> /opt/rt4/sbin/rt-server.fcgi/
> [Thu Jan 07 17:46:01.662020 2016] [core:info] [pid 20705] [client
> 117.218.246.102:29813] AH00130: File does not exist:
> /opt/rt4/sbin/rt-server.fcgi/404.shtml
> [Thu Jan 07 17:46:06.667355 2016] [ssl:info] [pid 20705] (70007)The
> timeout specified has expired: [client 117.218.246.102:29813] AH01991:
> SSL input filter read failed.
> [Thu Jan 07 17:46:06.667484 2016] [ssl:debug] [pid 20705]
> ssl_engine_io.c(1016): [client 117.218.246.102:29813] AH02001: Connection
> closed to child 13 with standard shutdown (server rt.consignweb.com:443)
>
> The file exists at /opt/rt4/sbin/rt-server.fcgi obviously. I can't seem to
> figure out where the problem is. Please help.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160107/98ff077d/attachment.html>


More information about the rt-users mailing list