[rt-users] Attachments don't reach database for one user

Chanel Wheeler Chanel.Wheeler at yavapai.us
Thu Mar 24 17:58:31 EDT 2016


Further experimentation has revealed that if the user sends an attachment by email it works (doesn’t via the web interface). Also, if I promote the user to the privileged level then she can add attachments via the web interface. I tried giving the unprivileged group all possible permissions but it had no effect.

chanel

From: Chanel Wheeler
Sent: Tuesday, March 15, 2016 9:31 AM
To: 'Dustin Graves'
Cc: rt-users at lists.bestpractical.com
Subject: RE: [rt-users] Attachments don't reach database for one user

Yes, everything in the ticket shows up for the faulty user except for the attachment. The rights for this user and other basic users of the system are the same.

chanel


From: Dustin Graves [mailto:dustin at bestpractical.com]
Sent: Monday, March 14, 2016 1:58 PM
To: Chanel Wheeler
Cc: rt-users at lists.bestpractical.com<mailto:rt-users at lists.bestpractical.com>
Subject: Re: [rt-users] Attachments don't reach database for one user


On Mar 10, 2016, at 5:09 PM, Chanel Wheeler <Chanel.Wheeler at yavapai.us<mailto:Chanel.Wheeler at yavapai.us>> wrote:

Hi all,
Hi Chanel,

I have one user that has used RT for a while with no problems. Recently, her attachments to web tickets ceased coming through. I’ve watched her add  attachments and they appear to upload successfully but there’s no trace of them in the Attachments table. We tried multiple browsers and the same thing happened on each. I logged in as her on my computer and still the problem happened. Another person logged in to RT on her computer and successfully attached items. So it’s something to do with her account. I’ve taken a look at her user record in the db and I don’t see anything amiss.

Any ideas on what I might try?

We’re running RT 4.4 and use LDAP for authentication.

I would start by checking the rights for these two users and how they might be different.

Can the faulty user see the missing attachment’s associated comment/correspondence? If the user cannot, that is why the attachment is missing. A user needs the ShowTicketComments right to see attachments added as part of a comment.

If this is not the problem, then I can investigate further.

Thanks!
chanel
Thank you,
Dustin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160324/cb72655a/attachment.html>


More information about the rt-users mailing list