[rt-users] Enabling full text index, getting "MySQL server has gone away"

Martin Wheldon martin.wheldon at greenhills-it.co.uk
Mon Nov 14 11:50:37 EST 2016

Hi Alex,

I think the mysql configuration be "max_allowed_packet" rather than 

Best Regards


On 2016-11-14 13:54, Alex Hall wrote:
> I should also say that I've already tried setting my MySQL
> max_packet_size. 500M didn't do it, so I upped it to 5000M, restarting
> the service both times. That hasn't changed the warnings I'm getting,
> and I really don't think any attachments are over 5GB. Plus, the first
> few warnings are that "st execute failed", not about attachments not
> being indexed.
> On Mon, Nov 14, 2016 at 7:46 AM, Alex Hall <ahall at autodist.com> wrote:
>> Hi all,
>> As the subject says, I'm trying to enable full text indexing. I've
>> updated MySQL to 5.7 (on Debian 8) and ran
>> /opt/rt4/sbin/rt-setup-fulltext-index --dba root --dba-password pwd
>> However, I get a bunch of warnings about executing the SQL
>> statements and, after that, that attachments can't be indexed. In
>> all cases, the main problem is the same: "the MySQL server has gone
>> away". The initial connection was successful, so I'm not sure what
>> the problem is. I also tested the root login after the 5.7 update,
>> just to be sure it worked, and it was fine. Has anyone ever seen
>> this happen? Any suggestions on what to do about it? Thanks!
>> --
>> Alex Hall
>> Automatic Distributors, IT department
>> ahall at autodist.com
> --
> Alex Hall
> Automatic Distributors, IT department
> ahall at autodist.com
> ---------
> RT 4.4 and RTIR training sessions, and a new workshop day!
> https://bestpractical.com/training
> * Los Angeles - January 9-11 2017

More information about the rt-users mailing list