[rt-users] Enabling full text index, getting "MySQL server has gone away"

James Zuelow James.Zuelow at juneau.org
Mon Nov 14 17:45:47 EST 2016


That’s good.  I was concerned that you had the same issue with MySQL 5.7 and the implications for RT on Stretch.

Max_allowed_packet does not work with 5.6.29 or 5.6.30 (at least not the Debian packages at those versions).


James



From: Alex Hall [mailto:ahall at autodist.com]
Sent: Monday, November 14, 2016 1:33 PM
To: James Zuelow
Cc: martin.wheldon at greenhills-it.co.uk; rt-users
Subject: Re: [rt-users] Enabling full text index, getting "MySQL server has gone away"

For future readers, my own solution was--thankfully--much simpler. Nowhere that I found in the docs I was reading did it say you had to add the max_allowed_packet setting under a section called [mysqld] in my.cnf. As soon as I did that, my setting took effect, and the full text setup ran perfectly.

On Mon, Nov 14, 2016 at 12:10 PM, James Zuelow <James.Zuelow at juneau.org<mailto:James.Zuelow at juneau.org>> wrote:
I had success by using Debian’s snapshot server and downgrading MySQL 5.6.27-2 and then running rt-setup-fulltext-index.  That worked perfectly.

You can safely “upgrade” back to your current version after the setup script runs – the fulltext index maintenance script will run fine.

If downgrading worked, please update my Debian bug report with the version that did not work for you:  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840780


James
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161114/fe2a8707/attachment.html>


More information about the rt-users mailing list