[rt-users] RT 4.2.9 (+ RTIR 3.2.0) Menus do not load all of a sudden this morning unless I turn $DevelMode on

Landon Stewart lstewart at internap.com
Mon Oct 17 14:52:01 EDT 2016


Hello,

This morning my team could not see the ticket history on tickets.  I changed the $ShowHistory setting to 'always' and this fixed that particular issue.  Then I noticed that the menus at the top of the pages were also not loading so I looked at the source of the page and saw a few JQuery errors.  I'm not 100% sure if those are relevant but when I turned $DevelMode on the issue's went away.

There were no changes made over the weekend.

With $DevelMode off (like it usually is) I see errors about squish-xxxx.js having an unexpected end of file.  I know RTIR caches these kinds of things in the mason_data/obj/ directory which is why I turned on $DevelMode to see if that fixed it.

What can I do or investigate to make things work again without $DevelMode turned on?  I'm not able to upgrade RT+RTIR quite yet but we plan to eventually.  I'd also like to delay the ticket history like it was before too but I suspect that these issues are related (javascript issues).

From my browser's developer console:

[cid:C0C704A7-5798-43D0-A14D-A9B693CE1756 at corp.iweb.com]

--
Landon Stewart
Lead Analyst - Abuse and Security Management
INTERNAP ®
📧 lstewart at internap.com<mailto:lstewart at internap.com>
🌍 www.internap.com<http://www.internap.com>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161017/1e86b80f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen Shot 2016-10-17 at 11.26.35 AM.png
Type: image/png
Size: 75955 bytes
Desc: Screen Shot 2016-10-17 at 11.26.35 AM.png
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161017/1e86b80f/attachment.png>


More information about the rt-users mailing list