[rt-users] FastCGI: comm with server "/opt/rt4/sbin/rt-server.fcgi" aborted: idle timeout (300 sec)

Nilesh me at nileshgr.com
Thu Sep 8 13:43:17 EDT 2016


On Thu, 2016-09-08 at 11:24 -0400, Pavneet Arora wrote:
> Okay, I have tried scouring the archives, but haven't found a solution
> to my problem, although rt-server.fcgi errors is mentioned with other
> issues.
> 
> Here is a summary of the configuration:
> 
> 1.  Originally, a working rt-4.2.10 installation under Ubuntu 14.04.  
>     Perl was installed locally and the following put in .bashrc to point 
>     to the correct version:
> 
>     PERL_MB_OPT="--install_base \"/home/<user>/perl5\""; export PERL_MB_OPT;
>     PERL_MM_OPT="INSTALL_BASE=/home/<user>/perl5"; export PERL_MM_OPT;
> 
> 2.  Recently upgraded to Ubuntu 16.04.1, and rt stopped working.
> 3.  Was getting the following error in /var/log/apache2/error.log:
> 
>     'FastCGI: server "/opt/rt4/sbin/rt-server.fcgi" has failed to remain
>     running for 30 seconds given 3 attempts, its restart interval has
>     been backed off to 600 seconds'
> 
>     The command for FastCGIServer in the site config also failed on the
>     command line:
> 
>     /opt/rt4/sbin/rt-server.fcgi -processes 5 -idle-timeout 300
> 
>     with an error about Perl module dependency.
> 4.  So, after much effort in trying to upgrade the old (local) Perl
>     installation and figuring that it was a Perl issue, I completely
>     disabled/removed the original Perl installation.
> 5.  Installed Perl 5.24.0 via perlbrew and then installed cpanm
> 6.  Set "export RT_FIX_DEPS_CMD=/opt/perl/bin/cpanm"
> 7.  Ran fixdeps.  Had to use --force to install Date::Manip, but other
>     than that have a fresh cpan.
> 8.  So clean Perl, and clean cpan.
> 9.  Did a reconfigure of rt-4.2.10 using the revised perlbrew directory, 
>     and a 'make install' (Backed up the original directory.  Copied over 
>     the old RT_SiteConfig.pm over to the new install directory.  Checked 
>     permissions: root:www-data.
> 9.  Problem is that I am still get the same errors related to
>     rt-server.fcgi.
> 
> Any guidance as to what might be the issue?
> 
> advTHANKSance.
> 
> 
What are the errors?

-- 
Nilesh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160908/ce612dcb/attachment.html>


More information about the rt-users mailing list