[rt-users] Database again stuck at SQLite?

Martin Wheldon martin.wheldon at greenhills-it.co.uk
Wed Sep 14 10:02:58 EDT 2016

Hi Alex,

I've not run a Debian packaged install for a long time, but looking at 
the package dependancies
I think the following may help.

How did you do the package install? If you ran the following it should 
just work.
$ sudo apt-get install request-tracker4 rt4-db-mysql

If however you just installed the request-tracker4 package it would 
install rt4-db-sqlite and you
will experience all kinds of issues like the ones you are describing.

The following should fix your issues:

$ sudo apt-get remove --purge request-tracker4 rt4-*
$ sudo apt-get autoremove
$ sudo apt-get install request-tracker4 rt4-db-mysql

Hope that helps


On 2016-09-14 13:00, Alex Hall wrote:
> Hello all,
> I'm getting a bit desperate. I have no idea why the setting in
> 51-dbconfig-common and the main SiteConfig.pm file are both 'mysql',
> but the error when my FCGI server starts clearly indicates that RT is
> trying to connect to a SQLite database. I've run update-rt-siteconfig,
> and I've tried to run dbconfig-common; the latter doesn't exist, and I
> just get an error from the shell that it doesn't know the command. The
> former works fine, as indicated by all the settings being in the .pm
> file, but never actually seems to apply those settings for some
> reason.
> I've even re-installed both RT and rt4-db-mysql, but that didn't make
> any difference as, for some reason, the initial package configuration
> for RT didn't appear. I've also changed the database type in
> /etc/dbconfig-common/request-tracker4.conf, but again, to no avail.
> Perhaps there's a way of applying dbconfig-common changes I don't
> know?
> If anyone has any ideas about how I might get RT on the right backend,
> please, please send them along. We haven't been able to move RT to a
> local server, and thus start testing it with a wider pool of users,
> for two days because of this problem. My boss isn't happy, and I'm
> stuck.
> On Tue, Sep 13, 2016 at 4:23 PM, Alex Hall <ahall at autodist.com> wrote:
>> Just a quick update. I've now tried changing the port and database
>> username, then re-applying the settings with update-rt-siteconfig.
>> They change just fine. Yet, the error in the log is still regarding
>> SQLite3, even though the database type is very clearly set to mysql.
>> I have no idea why the setting is right, but RT refuses to use it.
>> Please, if anyone knows how to troubleshoot this or re-run the
>> initial database setup, let me know. Thanks.
>> On Tue, Sep 13, 2016 at 7:07 AM, Alex Hall <ahall at autodist.com>
>> wrote:
>>> Hello all,
>>> I emailed last week asking a lot of questions, among them how to
>>> get my RT installation over to MySQL instead of SQLite3. Having
>>> moved to a company server, I'm again configuring RT, and I'm again
>>> stuck here. During the install, I accidentally hit enter at the
>>> database prompt rather than first hitting M. I figured I could
>>> change it later, so wasn't worried about it, especially as I'm now
>>> comfortable with how to update settings in RT.
>>> Yet, I can't seem to manage it. I've gone into
>>> RT_SiteConfig.d51dbconfig-common and made the changes, then issued
>>> update-rt-siteconfig
>>> and gotten confirmation that my configuration file was replaced,
>>> but the log continues to show that RT is trying to connect to
>>> SQLite. I've also restarted the RT service, and there's no server
>>> to restart since this database error kills the FCGI server
>>> immediately after it spawns. I've even restarted Nginx, though it
>>> shouldn't make a difference. I know there's a command to re-run
>>> the database configuration wizard, but I can't find it anywhere.
>>> Two things, then. What's the command to re-configure the database
>>> settings, and why might changing them in RT_SiteConfig.d and then
>>> running update-rt-siteconfig not make the changes I want? Thanks!
>> --
>> Alex Hall
>> Automatic Distributors, IT department
>> ahall at autodist.com
> --
> Alex Hall
> Automatic Distributors, IT department
> ahall at autodist.com
> ---------
> RT 4.4 and RTIR training sessions, and a new workshop day!
> https://bestpractical.com/training
> * Boston - October 24-26
> * Los Angeles - Q1 2017

More information about the rt-users mailing list