[rt-users] Database again stuck at SQLite?

Kenneth Marshall ktm at rice.edu
Wed Sep 14 09:52:08 EDT 2016

On Wed, Sep 14, 2016 at 09:00:48AM -0400, Alex Hall wrote:
> Hello all,
> I'm getting a bit desperate. I have no idea why the setting in
> 51-dbconfig-common and the main SiteConfig.pm file are both 'mysql', but
> the error when my FCGI server starts clearly indicates that RT is trying to
> connect to a SQLite database. I've run update-rt-siteconfig, and I've tried
> to run dbconfig-common; the latter doesn't exist, and I just get an error
> from the shell that it doesn't know the command. The former works fine, as
> indicated by all the settings being in the .pm file, but never actually
> seems to apply those settings for some reason.
> I've even re-installed both RT and rt4-db-mysql, but that didn't make any
> difference as, for some reason, the initial package configuration for RT
> didn't appear. I've also changed the database type in
> /etc/dbconfig-common/request-tracker4.conf, but again, to no avail. Perhaps
> there's a way of applying dbconfig-common changes I don't know?
> If anyone has any ideas about how I might get RT on the right backend,
> please, please send them along. We haven't been able to move RT to a local
> server, and thus start testing it with a wider pool of users, for two days
> because of this problem. My boss isn't happy, and I'm stuck.

Hi Alex,

I do not have any experience with your prebuilt packages. I always installed
it myself and then a simple reconfig worked. Have you tried uninstalling all
of the packages and re-installing from scratch with just the backend packages
that you need? Good luck.


More information about the rt-users mailing list