[rt-users] Enabling extensions in RT4.2.8?

Alex Hall ahall at autodist.com
Fri Sep 23 13:15:25 EDT 2016


Sorry for not replying in-line. I'd like to, but Google seems to have
broken something in their accessibility, and I can't navigate the quoted
text in my reply. The joys of using a screen reader.

To your questions: I ran strace, and I have a 1.5mb file of output. I don't
pretend to understand any of it, but I was scanning backwards from the
bottom, and I may have found the problem.

12875 stat("/var/cache/request-tracker4/mason_data/obj",
{st_mode=S_IFDIR|S_ISGID|0755, st_size=4096, ...}) = 0
12875
stat("/var/cache/request-tracker4/mason_data/obj/.__obj_create_marker",
0x1bf8238) = -1 ENOENT (No such file or directory)
12875
open("/var/cache/request-tracker4/mason_data/obj/.__obj_create_marker",
O_WRONLY|O_CREAT|O_TRUNC, 0666) = -1 EACCES (Permission denied)

When i cleared my mason cache, I deleted the obj folder as directed. It
looks like this process can't re-create the necessary structure inside the
mason_data directory. I've made www-data the owner, but as I'm invoking
this command as root, perhaps I need to do something different? I've also
given /var/cache/request-tracker4/mason_data 777 permissions recursively,
and that did the trick! What permissions should I set, though, to be sure
it's as secure as it needs to be? Oh, I should say, the FCGI command I use
is:

spawn-fcgi -u www-data -g www-data -a 127.0.0.1 -p 9876
/usr/share/request-tracker4/libexec/rt-server.fcgi

www-data is the same user used in Nginx, and I gather they have to match.

Anyway, back to the extension. Now that RT is running, I once again enabled
the plugin and updated my settings (yes, my main configuration file updates
as it should). But when I ran my FCGI command, I once again got the exit
code 255 message. I deleted sason_data/obj again, but that didn't help. I
reset the permissions, but that, too, did nothing. There's something odd
happening with the extension enabled that doesn't seem to happen with it
disabled. I'm not sure what the deal is, though. Has anyone ever seen this
happen with an extension?


On Fri, Sep 23, 2016 at 11:34 AM, Matt Zagrabelny <mzagrabe at d.umn.edu>
wrote:

> Hi Alex,
>
> On Fri, Sep 23, 2016 at 7:07 AM, Alex Hall <ahall at autodist.com> wrote:
> > Strange... I get an exit code of 255 on my FCGI server with the extension
> > enabled.
>
> Hmmm. Enabling extensions shouldn't be too complicated. There is
> nothing tricky going on.
>
>  If I comment out the lines in my Plugins file and update
> > siteconfig, I get no error code, but the server immediately quits
> silently.
> > There's nothing in any log to tell me what's going on, at least that I
> can
> > find.
>
> Is there a foreground option for your FCGI server?
>
> Run it through strace?
>
> strace -f /some/path/to/your/fcgi-server
>
>  RT was working perfectly until I installed and enabled the
> > PriorityAsString extension, though I don't know if the install itself or
> the
> > attempt to modify my settings did it.
>
> Check the actual siteconfig file after running your update-rt-siteconfig.
>
> % view /etc/request-tracker4/RT_SiteConfig.pm
>
> and see if the PriorityAsString is commented out or not.
>
> > Is there a way to remove an extension so I can start over?
>
> You'd remove the files on disk. I'm not sure if the makefile that is
> generated has an uninstall target.
>
> Now that we're talking about it, did you use the RTHOME variable to
> set your RT libs when generating the makefile for the extension?
>
> % tar xvfz some-rt-extension.tar.gz
> % cd some-rt-extension
> % RTHOME=/usr/share/request-tracker4/lib perl Makefile.PL
>
>  I installed using
> > the commands on its homepage, not CPAN, so I don't know if that caused a
> > problem. I don't see any uninstall/remove commands on the plugin's page,
> but
> > maybe there's a standard way using Perl commands that I don't know?
>
> If there were a standard way, then it would be the makefile that gets
> generated would have an uninstall target.
>
> -m
>



-- 
Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160923/b843d49d/attachment.html>


More information about the rt-users mailing list