[rt-users] Enabling extensions in RT4.2.8?

Alex Hall ahall at autodist.com
Fri Sep 23 15:43:11 EDT 2016

I'll run the install again and hope that doing so won't cause any problems.

root at server24:/home/ahall/RT-Extension-PriorityAsString-1.04# perl
Using RT configuration from /usr/share/request-tracker4/lib/RT.pm:
html       =>
lib        =>
Generating a Unix-style Makefile
Writing Makefile for RT::Extension::PriorityAsString
Writing MYMETA.yml and MYMETA.json

root at server24:/home/ahall/RT-Extension-PriorityAsString-1.04# make
Skip blib/lib/RT/Extension/PriorityAsString.pm (unchanged)
Manifying blib/man3/RT::Extension::PriorityAsString.3pm

root at server24:/home/ahall/RT-Extension-PriorityAsString-1.04# make install
Appending installation info to
Couldn't load RT config file RT_SiteConfig.pm:

Can't locate object method "InitPluginPaths" via package
"RT::Extension::PriorityAsString" (perhaps you forgot to load
"RT::Extension::PriorityAsString"?) at
/usr/share/request-tracker4/lib/RT.pm line 654.
Compilation failed in require at
/usr/share/request-tracker4/lib/RT/Config.pm line 1106.
Makefile:796: recipe for target 'install' failed
make: *** [install] Error 255

Well, that's new. Obviously this is the source of the trouble, but what
does it mean and how do I fix it? As far as I remember, I didn't see this
on my last install, but I'm glad it's here now if it illuminates the core
problem! And no, I think I missted the RTHOME comment. I'm going to search
for it as soon as I send this.

On Fri, Sep 23, 2016 at 3:31 PM, Matt Zagrabelny <mzagrabe at d.umn.edu> wrote:

> On Fri, Sep 23, 2016 at 2:20 PM, Alex Hall <ahall at autodist.com> wrote:
> > Okay, good to know about the permissions and deleting everything below
> > mason_data/obj. I re-created the obj directory and set it to
> > www-data:www-data 755.
> >
> > I ran perl -c on the main config file, with the two plugin lines
> commented
> > out and not, and on the RT_SiteConfig.d/70-plugins file I made that holds
> > those lines. In all three cases, Perl reports that the syntax is okay.
> >
> > To make sure I'm not going nuts from all the things I've tried recently,
> I
> > tested things once more. I commented out the plugin lines, ran
> > update-rt-siteconfig and update-rt-siteconfig-4 (what's the difference?),
> update-rt-siteconfig is a symlink. It points to
> update-rt-siteconfig-4. The command is obsolete in 4.4 since RT
> natively supports config snippets without needing a command to
> regenerate a site config.
> > and tried to spawn the FCGI server. It worked. Uncommented, and the FCGI
> > server exited with status code 255 when not commented. Oh, between the
> two
> > attempts I also ran the delete command you sent. Is there a step I'm
> > missing? Maybe something so obvious you didn't think to mention it? This
> is
> > clearly atypical for RT plugins, so it almost has to be something I'm
> > missing/doing wrong.
> What did you do to install the module?
> Did you read my comment in a previous email about RTHOME?
> Please list the exact commands and their output.
> wget or curl?
> tar?
> perl Makefile.PL?
> etc.
> Maybe we'll see something.
> -m

Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160923/6dac3524/attachment.htm>

More information about the rt-users mailing list