[rt-users] Enabling extensions in RT4.2.8?

Matt Zagrabelny mzagrabe at d.umn.edu
Fri Sep 23 15:31:35 EDT 2016

On Fri, Sep 23, 2016 at 2:20 PM, Alex Hall <ahall at autodist.com> wrote:
> Okay, good to know about the permissions and deleting everything below
> mason_data/obj. I re-created the obj directory and set it to
> www-data:www-data 755.
> I ran perl -c on the main config file, with the two plugin lines commented
> out and not, and on the RT_SiteConfig.d/70-plugins file I made that holds
> those lines. In all three cases, Perl reports that the syntax is okay.
> To make sure I'm not going nuts from all the things I've tried recently, I
> tested things once more. I commented out the plugin lines, ran
> update-rt-siteconfig and update-rt-siteconfig-4 (what's the difference?),

update-rt-siteconfig is a symlink. It points to
update-rt-siteconfig-4. The command is obsolete in 4.4 since RT
natively supports config snippets without needing a command to
regenerate a site config.

> and tried to spawn the FCGI server. It worked. Uncommented, and the FCGI
> server exited with status code 255 when not commented. Oh, between the two
> attempts I also ran the delete command you sent. Is there a step I'm
> missing? Maybe something so obvious you didn't think to mention it? This is
> clearly atypical for RT plugins, so it almost has to be something I'm
> missing/doing wrong.

What did you do to install the module?

Did you read my comment in a previous email about RTHOME?

Please list the exact commands and their output.

wget or curl?
perl Makefile.PL?


Maybe we'll see something.


More information about the rt-users mailing list