[rt-users] writing extensions for an old version

Martin Wheldon martin.wheldon at greenhills-it.co.uk
Mon Feb 13 12:18:07 EST 2017


If you look in the Makefile.PL you will find somethink like this

requires_rt '4.0.0';

modify as required.

Can I suggest that you upgrade as v3.8 reached end of life in 2014.

Best Regards


On 2017-02-13 17:02, Vinicius Fagundes wrote:
> Hi,
> I'm starting to learn RT development. And I was designated to create a
> RT extension, but our RT version is too old (3.8). I couldn't find any
> documentation about how to do it for this version.
> I tried follow the current documentation but when I tried to run:
> perl Makefile.PL
> I got this error:
> **** Error: This extension requires RT 4.0.0. Your installed version
>             of RT (3.8.8) is too old.
> Is it possible write and run a Extension for this version? If so, how
> can I achieve that.
> Vinícius _Fagundes_

More information about the rt-users mailing list