[Rtir] no charts available in request tracker installed from source

Kevin Falcone falcone at bestpractical.com
Tue Oct 21 17:31:19 EDT 2014

On Mon, Oct 20, 2014 at 09:50:10AM +0000, marek.kreul at lhsystems.com wrote:
> interesting - I would have never thought that such an "unrelated" plugin could cause such an issue.

Plugins (and any local customizations) can always cause problems like

> You're right, we are using ExternalAuth (and
> RT::Extension::ExtractCustomFieldValues), and I've upgraded the plugin
> to ExternalAuth 0.25 today - without success (checked by accessing the
> "theme" config page --> message "GD is disabled or not installed. You
> can upload an image, but you won't get automatic color suggestions."

So, that doesn't mean Logos are broken, it just means you have GD
installed without png, jpeg or gif support.  I'm not quite sure how
you've managed that.  Perhaps look for additional gd- packages you
should have installed.

> Then, I tried disabling all plugins in RT_SiteConfig.pm, which solved the issue.
> Re-Enabling ExternalAuth broke the charting again, so I guess the bug in correlation with ExternalAuth still exists.

So, since you keep referring to the GD Is disabled message, which is
different from "is broken" can you be specific about what kind of
"breakage" you see with charting?  I had thought you meant that the
graph doesn't show up at all, or is a broken image link, but since you
claim that RT-Authen-ExternalAuth 0.25 still breaks it, I find that
hard to believe.

This may all be tied to your lack of gd library support referenced

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 221 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rtir/attachments/20141021/aeea8d25/attachment.pgp>

More information about the rtir mailing list