[Rtir] no charts available in request tracker installed from source

marek.kreul at lhsystems.com marek.kreul at lhsystems.com
Fri Oct 24 08:44:21 EDT 2014

Hi Kevin,

I've uploaded a screenshot of how the broken graphics look like here:
and here:

I've also tried installing additional gd packages, which didn't bring any results - which is obvious, because as soon as ExternalAuth is disabled, graphing works.
So it clearly must be correlated with the ExternalAuth package.

Kind regards,

Sitz der Gesellschaft / Corporate Headquarters: Lufthansa Systems Aktiengesellschaft, Kelsterbach, Registereintragung / Registration: Amtsgericht Darmstadt 84307
Vorsitzende des Aufsichtsrats / Chairperson of the Supervisory Board: Simone Menne
Vorstand / Executive Board: Stefan Hansen (Vorsitzender / Chairman), Dr. Gunter Kuechler
-----Original Message-----

From: rtir [mailto:rtir-bounces at lists.bestpractical.com] On Behalf Of Kevin Falcone
Sent: Tuesday, October 21, 2014 11:31 PM
To: rtir at lists.bestpractical.com
Subject: Re: [Rtir] no charts available in request tracker installed from source

On Mon, Oct 20, 2014 at 09:50:10AM +0000, marek.kreul at lhsystems.com wrote:
> interesting - I would have never thought that such an "unrelated" plugin could cause such an issue.

Plugins (and any local customizations) can always cause problems like this.

> You're right, we are using ExternalAuth (and 
> RT::Extension::ExtractCustomFieldValues), and I've upgraded the plugin 
> to ExternalAuth 0.25 today - without success (checked by accessing the 
> "theme" config page --> message "GD is disabled or not installed. You 
> can upload an image, but you won't get automatic color suggestions."

So, that doesn't mean Logos are broken, it just means you have GD installed without png, jpeg or gif support.  I'm not quite sure how you've managed that.  Perhaps look for additional gd- packages you should have installed.

> Then, I tried disabling all plugins in RT_SiteConfig.pm, which solved the issue.
> Re-Enabling ExternalAuth broke the charting again, so I guess the bug in correlation with ExternalAuth still exists.

So, since you keep referring to the GD Is disabled message, which is different from "is broken" can you be specific about what kind of "breakage" you see with charting?  I had thought you meant that the graph doesn't show up at all, or is a broken image link, but since you claim that RT-Authen-ExternalAuth 0.25 still breaks it, I find that hard to believe.

This may all be tied to your lack of gd library support referenced above.


More information about the rtir mailing list