[svk-devel] revision number weirdness and work stoppage

Michael Brouwer mb.7766 at gmail.com
Fri Apr 27 12:25:33 EDT 2007

If you are the only one working with your repo, why are you even making a
local copy of the tree in your svk depot?  You know you can checkout a
working copy directly from a mirrored path and commit to it right?  Then you
don't need svk push/svk pull, unless you are making a local branch to work
on some change off line.

I think what might be going wrong is that your local branch is at the level
of the whole tree, and your working copy checkouts are just a subtree like
trunk.  Since svk only keeps merge tracking information at a single level in
the project hierarchy, you always want to branch and merge at the same
level, so always branch from trunk, or branches/foo or tags/foo, but if you
branch trunk/bar and try to use smerge, it won't take into account any
merges done at the trunk level.


On 4/27/07, Michael Peters <mpeters at plusthree.com> wrote:
> Brice Figureau wrote:
> > What gives:
> > svk info //local/krang/trunk/krang
> [mpeters at localhost krang_again]$ cd
> [mpeters at localhost ~]$ svk info //local/krang/trunk/krang
> Depot Path: //local/krang/trunk/krang
> Revision: 27430
> Last Changed Rev.: 27412
> Copied From: /mirror/krang/trunk/krang, Rev. 26193
> Merged From: /mirror/krang/trunk/krang, Rev. 26193
> Merged From: /local/krang/trunk/krang, Rev. 22312
> So it doesn't appear that it mentions #27397 there.
> > Does ~/.svk/local/db/revs contains a file named 27397 ?
> It does now.
> [mpeters at localhost ~]$ ls .svk/local/db/revs/27397
> .svk/local/db/revs/27397
> But I don't know if this is just an artifact of when I tried to push my
> repo
> past 27397 with garbage commits.
> > Maybe that's just ~/.svk/config that contains an "invalid" entry ?
> I really wish it would be that easy. But I moved my .svk/config to
> .svk/config.bak and tried checking out a new copy of
> //local/krang/trunk/krang
> and then pulling in the recent changes and all I get is
> Auto-merging (26199, 27430) /mirror/krang/branches/ajax_and_new_skin to
> /local/krang/branches/ajax_and_new_skin (base
> /local/krang/trunk/krang:22312\n689d98c0-9023-0410-9c0b-f79783857903:/branches/ajax_and_new_skin:3771\n689d98c0-9023-0410-9c0b-f79783857903:/trunk/krang:3802\n6cb60ec2-19fc-4f48-ba02-516b4c84136d:/local/krang_ajax_and_new_skin:28207\n6cb60ec2-19fc-4f48-ba02-516b4c84136d:/local/krang_trunk/krang:27397).
> Filesystem has no item: File not found: revision 27397, path
> '/local/krang/trunk/krang:22312\n689d98c0-9023-0410-9c0b-f79783857903:/branches/ajax_and_new_skin:3771\n689d98c0-9023-0410-9c0b-f79783857903:/trunk/krang:3802\n6cb60ec2-19fc-4f48-ba02-516b4c84136d:/local/krang_ajax_and_new_skin:28207\n6cb60ec2-19fc-4f48-ba02-516b4c84136d:/local/krang_trunk/krang'
> > And if you get a working copy of //local/krang/trunk/krang, at which
> > revision are you ?
> 27424
> > Maybe fixing the config file could be enough to push your changes (this
> > is a complete blind suggestion).
> >
> > Other than that, maybe you can push by doing a manual smerge against the
> > latest known revision of your current working copy.
> Nope, doing another smerge results in the same error: Filesystem has no
> item:
> File not found: revision 27397.
> I've gone back to working with svn for now. If I feel like gambling again,
> I
> might just remove all my svk stuff and start from scratch.
> --
> Michael Peters
> Developer
> Plus Three, LP
> _______________________________________________
> svk-devel mailing list
> svk-devel at bestpractical.com
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/svk-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.bestpractical.com/pipermail/svk-devel/attachments/20070427/2120993f/attachment.htm

More information about the svk-devel mailing list