[svk-devel] revision number weirdness and work stoppage

Michael Peters mpeters at plusthree.com
Fri Apr 27 10:50:48 EDT 2007

Brice Figureau wrote:

> What gives:
> svk info //local/krang/trunk/krang

[mpeters at localhost krang_again]$ cd
[mpeters at localhost ~]$ svk info //local/krang/trunk/krang
Depot Path: //local/krang/trunk/krang
Revision: 27430
Last Changed Rev.: 27412
Copied From: /mirror/krang/trunk/krang, Rev. 26193
Merged From: /mirror/krang/trunk/krang, Rev. 26193
Merged From: /local/krang/trunk/krang, Rev. 22312

So it doesn't appear that it mentions #27397 there.

> Does ~/.svk/local/db/revs contains a file named 27397 ?

It does now.

[mpeters at localhost ~]$ ls .svk/local/db/revs/27397

But I don't know if this is just an artifact of when I tried to push my repo
past 27397 with garbage commits.

> Maybe that's just ~/.svk/config that contains an "invalid" entry ?

I really wish it would be that easy. But I moved my .svk/config to
.svk/config.bak and tried checking out a new copy of //local/krang/trunk/krang
and then pulling in the recent changes and all I get is

Auto-merging (26199, 27430) /mirror/krang/branches/ajax_and_new_skin to
/local/krang/branches/ajax_and_new_skin (base
Filesystem has no item: File not found: revision 27397, path

> And if you get a working copy of //local/krang/trunk/krang, at which
> revision are you ?


> Maybe fixing the config file could be enough to push your changes (this
> is a complete blind suggestion).
> Other than that, maybe you can push by doing a manual smerge against the
> latest known revision of your current working copy. 

Nope, doing another smerge results in the same error: Filesystem has no item:
File not found: revision 27397.

I've gone back to working with svn for now. If I feel like gambling again, I
might just remove all my svk stuff and start from scratch.

Michael Peters
Plus Three, LP

More information about the svk-devel mailing list