[svk-devel] Using svk to mirror a svn repos and problem with UTF-8 (??)

Marc Poulhiès marc.poulhies at imag.fr
Fri May 11 10:33:33 EDT 2007


I'm trying to have a svn repository mirrored by using svk. I tried to
follow the different documentation I found, in particular this one:


I'm following the second part (local mirror).
So, here are the commands I used:

$ svk mirror svn://somehost/svnroot/think //mirror/think-ow
$ svk sync //mirror/think-ow
$ svk cp -p //mirror/think-ow //local/think-ow

Then, if I believe the wiki, I should do:

$ svn co -p file:///home/user/.svk/local/think-ow think-ow

But there is no such directory in .svk, and 'svn co' does not know about
'-p' flag...

I found that ~/.svk/local is actually a svn repos where I can use
svnadmin, so I tried to checkout directly :

$ svn co ~/.svk/local .
svn: Valid UTF-8 data
(hex: 52)
followed by invalid UTF-8 sequence
(hex: e9 67 6c 65)

I can't find any clear solution to this. I read that this can be caused
by the files encoding, but I'm surprised that I can run "svnadmin
verify", that I can mirror/sync without any problem. svn directly on the
remote repository is of course working fine.

I'm not sure this is a bug (even if it looks like one).
I'm using both svn and svk from debian sid:

$ svn --version
svn, version 1.4.2 (r22196)
   compiled Nov 10 2006, 17:39:50

$ svk --version
This is svk, version v2.0.1 (using Subversion bindings 1.4.2)

Any hint possible ? Maybe I didn't find the correct documentation ?


PS: it's possible you receive this mail twice. The first time I received
a strange answer from SYMPA with strange characters inside...

More information about the svk-devel mailing list