[svk-devel] Current 2.0-releng branch (and 2.0.1) fail tests on Fedora 7

Derek Atkins warlord at MIT.EDU
Tue May 15 11:40:31 EDT 2007

Hmm, I dont recall seeing this on the list, but I might've
missed the relevance when it came across.  Is this an actual
bug in the code or is it just a bug in the test?  If the latter
then I should be able to install and use SVK now, but if it's
the former then I should wait for your patch to get committed.



"Chia-Liang Kao" <clkao at clkao.org> writes:

> That seems to be the unstable tests which a patch on the list is to
> fix.  I will get it committed and merged to 2.0-releng.
> On 15/05/07, Derek Atkins <warlord at mit.edu> wrote:
>> I've got a Fedora 7 system and I'm trying to install SVK.
>> I tried 2.0.1 from CPAN and it failed to install because of
>> some failed tests.  So I tried installing from 2.0-releng
>> and got the same failures.  I suspect I can at least get
>> it to install manually, but I wanted to let people know:
>> t/mirror/sync-crazy-replace......ok 1/21
>> #   Failed test 'rm t/checkout/sync-crazy-replace/A-copy/Q'
>> t/mirror/sync-crazy-replace......NOK 2#   in t/mirror/sync-crazy-replace.t at line 27.
>> #     Structures begin differing at:
>> #          $got->[1] = 'D   t/checkout/sync-crazy-replace/A-copy/Q/qz'
>> #     $expected->[1] = 'D   t/checkout/sync-crazy-replace/A-copy/Q/qu'
> Cheers,
> _______________________________________________
> svk-devel mailing list
> svk-devel at bestpractical.com
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/svk-devel

       Derek Atkins, SB '93 MIT EE, SM '95 MIT Media Laboratory
       Member, MIT Student Information Processing Board  (SIPB)
       URL: http://web.mit.edu/warlord/    PP-ASEL-IA     N1NWH
       warlord at MIT.EDU                        PGP key available

More information about the svk-devel mailing list