[rt-users] Migration Prep

Paul O'Rorke paul at tracker-software.com
Tue Jul 30 18:17:11 EDT 2013


Thanks for that Kevin,

not the first time - a silly little mistake had me scratching my head.  
I had in my Apache config a rewrite rule for /rt and had the wrong value 
in RT_Siteconfig for Set($WebPath, '');

So I now get my logon screen but cannot log in.

I did run the password updater:

    root at rt4:/opt/rt4# perl /opt/rt4/etc/upgrade/vulnerable-passwords --fix
    Upgrading 16 users...
    Done.

I am assuming that I can't just UPDATE the passwords in MySQL because of 
the hashing?  I tried without success:

    mysql> UPDATE rtdb.Users SET Password=PASSWORD('xxxx') WHERE
    Name='jamie';
    Query OK, 1 row affected, 1 warning (0.01 sec)
    Rows matched: 1  Changed: 1  Warnings: 1

I guess I have missed something in these upgrade README files.  I do 
appreciate your help.  Now that I've the Apache thing sorted I'm feeling 
like on the home stretch - if only I can sort these passwords out.  Is 
there another related script I missed perhaps?

Sincerely

Paul O'Rorke
Tracker Software Products Canada Limited

paul at tracker-software.com <mailto:paul at tracker-software.com>
tracker-software.com <http://tracker-software.com>

Tel: +1 (250) 324 1621
Fax: +1 (250) 324 1623

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

PLEASE NOTE : - If you are sending files for us to look at or assist with
these must ALWAYS be wrapped in either a ZIP/RAR or 7z FILE
or they will be removed by our Firewall/Virus management software.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++

**Certified by Microsoft**
"Works with Vista"
PDF-XChange & SDK, Image-XChange SDK,
PDF-Tools & SDK, TIFF-XChange & SDK.

Support:
http://docu-track.com/support/ <http://tracker-software.com/support/>
or
http://www.tracker-software.com/forum/index.php 
<http://tracker-software.com>


Download latest Releases
http://www.tracker-software.com/downloads/ 
<http://tracker-software.com/downloads>
On 07/30/2013 07:42 AM, Kevin Falcone wrote:
> On Mon, Jul 29, 2013 at 02:30:35PM -0700, Paul O'Rorke wrote:
>>     In the meanwhile I am finding that after running make upgrade-database (took me through all
>>     the upgrades from 3.8.4 to 4.0.15) and then trying to set up Apache again I'm running into a
>>     loop on the login page.  If I run Apache I don't get a login page at all.  If I stop Apache
>>     and start
> Are you running your 3.8 Apache config or a new 4.0 config.
> We can't help debug that problem without seeing error logs or a
> config.
>
>>   /opt/rt4/sbin/rt-server
>>
>>     then I get:
> You don't say what you did to cause this.  Load the login page?
> Attempt to log in?  There are clearly a few actions mixed in there.
>
> Also - did you run the password updater, either as a security fix back
> in 3.8 or more recently as part of the upgrade?
> http://bestpractical.com/docs/rt/latest/UPGRADING-3.8.html
>
> -kevin
>
>>     Reason: your browser did not supply a Referrer header
>>     (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:397)
>>     [Mon Jul 29 21:25:46 2013] [notice]: Marking original destination as having side-effects
>>     before redirecting for login.
>>     Request: /rt/NoAuth/Login.html?next=d820f5cbf943dfe116cbee257b840411
>>     Reason: your browser did not supply a Referrer header
>>     (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:397)
>>     [Mon Jul 29 21:26:00 2013] [error]: FAILED LOGIN for root from 192.168.0.254
>>     (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:753)
>>     [Mon Jul 29 21:26:12 2013] [error]: FAILED LOGIN for rtuser from 192.168.0.254
>>     (/opt/rt4/sbin/../lib/RT/Interface/Web.pm:753)
>>     I'm assuming I've not actually managed to get my database upgraded properly as I'm very
>>     confident of the credentials used (tried others as well that worked in 3.8.4).  After running
>>     make upgrade-database do I still need to do the individual upgrades in each of the README
>>     files for the various updates or does make upgrade-database effectively do the same?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20130730/80a8028b/attachment-0001.html>


More information about the rt-users mailing list