[Rt-devel] Two problems with rt-3.9.7

Kevin Falcone falcone at bestpractical.com
Wed Dec 29 12:51:33 EST 2010

On Wed, Dec 29, 2010 at 08:22:41PM +0300, Odhiambo Washington wrote:
>    On Wed, Dec 29, 2010 at 7:24 PM, Kevin Falcone <[1]falcone at bestpractical.com> wrote:
>      On Wed, Dec 29, 2010 at 07:02:31PM +0300, Odhiambo Washington wrote:
>      > Â Â Hi everyone,
>      >
>      > Â Â I'm testing rt-3.9.7 and two problems are tying me down. It's quite some time since I
>      used RT
>      > Â Â actively so I'm trying to catch up.
>      > Â Â The first is related to Resolved template. I have the following template -
>      > Â Â [1][2]http://inetpro.org/pastebin/10622 - which worked in RT (I can't tell which
>      version is
>      > Â Â worked with lastly. Probably 3.6.x) but is simply not being accepted in 3.9.7. What
>      changes do
>      How is not accepted?
>    I get this error:
>    Can't use string ("Subject: [{$rtname} #{$Ticket->i") as an ARRAY ref while "strict refs" in
>    use at /opt/rt4/sbin/../lib/RT/Template_Overlay.pm line 678, line 69.

You're missing a trailing } on your template (in the resolution
comment block) which appears to really break the compile checker.

>    Sure. I have taken a slap for that! I'd assumed so much that Everyone means "everyone".

You almost certainly don't want Everyone to have ShowTicket, that
means they can see any ticket.  You want Requestors to see their own

>    I have taken a snapshot of the main login window. You can see it here as a pdf:
>    [3]http://lix.in/-91f606
>    I am using web2 theme and I simply cannot navigate the RT display in Firefox-4.0b8. I simply
>    have to close the tab. Trying to click on links which behave like moving targets is not easy,
>    oh!
>    The hyperlink to "Logged in as .." actually is shown on the right hand top corner, as opposed
>    to left hand top corner with Chrome.

Do you seem similar breakage on aileron?

>    Bar from getting git source, is there a nightly snapshot of current HEAD that I can try? I
>    didn't find a way to compile HEAD the way I do with the distributed tarballs.

There should be another tarball along soon.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-devel/attachments/20101229/b6a58088/attachment.pgp>

More information about the rt-devel mailing list