[rt-users] Problems with mailgateway

Jesper Holm Olsen dunkel at diku.dk
Tue Mar 7 10:24:50 EST 2000

Ok. I found the error. Postfix' replacement copy of sendmail had been
overwritten by a Solaris update patch, so I was invoking the original
sendmail :-|

BUT all my problems are still not solved! If I choose 'reply' to an entry,
the 'TO' field is set to the requester as it should. If I choose 'send
response', it seems (from the syslog) that 'sendmail' never gets invoked.
If I however fill out the 'CC' field (with the same adress as in the 'TO'
field), 'sendmail' gets called and sends the message ok.

Could it be a bug in rt?

On Mon, 6 Mar 2000, Jesse wrote:

>     #set this to whatever program you want to send the mail that RT generates
>     #be aware, however, that RT expects to be able to set the From: line
>     #with sendmail's command line syntax
>     $mailprog = "/usr/sbin/sendmail";
>     $mail_options = "-oi -t ";
> On Mon, Mar 06, 2000 at 04:06:36PM +0100, Jesper Holm Olsen wrote:
> > On Fri, 3 Mar 2000, Jesse wrote:
> > 
> > > Well, I'm also running RT with postfix. and it works great.
> > > Make sure that the user postfix is running as can actually _get_ to rt/bin.
> > > 
> > 
> > Ok. I set the global execute bit on the /rt/bin dir and now I can
> > _recieve_ mail :-)
> > 
> > Unfortunatly I cannot _send_ mail (unless its adressed to the local
> > server). When I watch the syslog it seems like postfix never gets invoked,
> > if the email adress is something other than the local servers domain.
> > 
> > How have you set up the mailconfiguration in /rt/etc/config.pm?

Jesper Holm Olsen,  Department of Computer Science and Department of 
                    Film and Media studies, University of Copenhagen
Email: dunkel at diku.dk * Homepage: http://www.diku.dk/students/dunkel

More information about the rt-users mailing list