[rt-users] mail GW failing for hotmail users but working from others!

Fabrice Laborie laborie at sbm.net.sa
Tue May 16 03:44:18 EDT 2000

Hi Fergal !

> I've never actually been too clear on the differences between action, and
> correspond queues...
> When I first set up, I created two aliases for each queue  - e.g.
> techies: |"/usr/local/rt/bin/rt-mailgate testq1 correspond
> techies-action: |"/usr/local/rt/bin/rt-mailgate testq1 action
I still don't see what the ACTION is for ... but I will leave that for
later ...
> Your fethcmail rc should look something like:
> poll mail.sbm.com
> protocol APOP
> username testq1 pass XfghyT7VChuP9BBHJH9
> mda "/usr/local/rt/bin/rt-mailgate techies correspond"
yeah that's what I have except that I use pop and not apop .... I guess
I should switch,
you are right .... never nice to have password in clear, even if
fetchmail forces you to chmod
your .fetchmailrc for more privacy ;-)

> I recall having problems until I specifically quoted the mda. Assuming this is
> all working then I suspect that you're not receiving the full headers. As far
> as I know, RT relies on the subject line alone to figure out the serial number
> of a reply (see rt/lib/rt/mail parse_header function). I had being thinking
> about doing a loose match hack
> The references header is part of RFC 822 and is intended to indicate that one
> e-mail is referring to another  - i.e. a reply of sorts, Used for threading
> messages on thingsa like Usenet. I didn't think RT used it, I haven't really
> checked, so maybe it does... Jesse?

I looked up in the code ... and the only  X-RT header which is parsed
is X-RT-Loop-Prevention ... 
so it looks like "X-Request-ID:"  is not expected to be sent back....
nor the "References:" ......

and you are right, only the subject is used to extract the serial number
for further processing.
123     elsif (($line =~
/^Subject:(.*)\[$rt::rtname\s*\#(\d+)\]\s*(.*)/i) and (!$subject)){
124       $serial_num=$2;
125       &rt::req_in($serial_num,$current_user);
126       $subject=$3;
127       $subject =~ s/\($rt::req[$serial_num]{'queue_id'}\)//i;
128     }           

this means that the reply from Hotmail SHOULD work and the mailgw SHOULD
process it normally.
( btw in the mean time I tried from other domains/other mailers ....
Lotus Notes 5 worked perfectly ;-)

any idea ?????????
this is realllllllly strange to me any body has experience this kind of
problem ?

could someone test this from his stable installation of RT ? ( I could
reply to a Request send form some
one from this mailing list.......)

> Check your aliases and mda are correct, and if not, send a reply from hotmail
> to another account to make sure the mailgate isn't losing the header.
I tried that ... and the Ref header is NOT sent ... although now from
the code it seems that this is not
taken into account by the mailgw .....

> Stuff, Blah, I'm boring.
nahhhhhhhh helfull ;-)

Go mbeannaí Dia sibh. 


More information about the rt-users mailing list