[rt-users] mail problems instead with postfix and 2.0.0(aka, what next)

Dikeman, Brett brett.dikeman at proactcorp.com
Wed Jun 27 20:25:53 EDT 2001

Whenever I send mail to the ticketing system(2.0.0, Mandrake 7.2, Postfix
for an MTA) I get:

<itsupport at somehost.company.com>: Command died with status 2:
    "/home/rt2/bin/rt-mailgate --queue ITsupport --action correspond".
    output: Can't locate config.pm in @INC (@INC contains: /home/rt2/etc
    /home/rt2/lib /usr/lib/perl5/5.6.1/i686-linux /usr/lib/perl5/5.6.1
    /usr/lib/perl5/site_perl/5.6.1/i686-linux /usr/lib/perl5/site_perl/5.6.1
    /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .) at
    /home/rt2/lib/RT/Interface/Email.pm line 81. BEGIN failed--compilation
    aborted at /home/rt2/lib/RT/Interface/Email.pm line 81. Compilation
    in require at /home/rt2/bin/rt-mailgate line 18. BEGIN
    aborted at /home/rt2/bin/rt-mailgate line 18.

I've tried everything I can think of.  I've tried:
-adding postfix to the "rt" group(config.pm is group-owned by "rt")
-running the above command as the postfix user(ie, su - postfix, then the
command above)

The command works when I run it(well, "works"= sits there, no errors), and
it's obvious config.pm is in the right place.  Has anyone successfully
installed 2.0.0 on a postfix system?

Much appreciated!


More information about the rt-users mailing list