[rt-users] Scrip installation blues

Feargal Reilly feargal at thecia.ie
Fri Nov 9 11:21:32 EST 2001

Ick! Jesse and I had been discussing the best way to handle user-contributed scrips, and as a result I knocked that together. The original plan was to include it in RT itself at some point. 
I'd sent it to Jesse as a "heres what's been done so far", it really shouldn't have hit the contrib directory at all.

I'll have a go at bringing it up to date over the weekend - It hasn't been touched since RT was in the 1.3 tree, Jesse can you take it out of contrib?

The Autoassign scrip itself should work though.

Check that helgrim.com-AutoAssign.pm is in rt/lib/RT/Action

In mysql, do a 'SELECT name,argument,execmodule FROM scripactions;'
There should be two entries:
name                            argument     execmodule
helgrim.com-AutoAssignAdminCc | AdminCc    | helgrim.com-AutoAssign
helgrim.com-AutoAssignAnyCc   | AdminCc,Cc | helgrim.com-AutoAssign

If not, update them by hand.

If that's still not working, can you wait till Monday so I can check it out.


On Fri, 2 Nov 2001 14:58:18 -0600 , "Beachey, Kendric" <Kendric.Beachey at garmin.com> wrote:

> I'm trying to install Feargal's auto assign scrip from the contrib area on
> fsck.com.
> I'm behind a firewall that requires authentication, so Feargal's "rt-scrips"
> script couldn't retrieve the scrip, so I had to grab it myself.
> I made sure to install Archive::Tar, but rt-scrips still complained that it
> couldn't uncompress the archive, so I did that myself too.
> Then (I'm full of problems today!) rt-scrips wouldn't quit trying to
> uncompress the archive, so I short-circuited that part of the script.
> Now rt-scrips would happily install the modules into place.  It was nice to
> see something working.  :-)  But to get the data to install, I had to strip
> out all of the rt-scrips script except the data installation part, and
> hardwire a couple of strings.  But it finally did get the data installed:
> [root at zimmerdale helgrim.com-AutoAssign]# /opt/rt2/bin/kb-rt-scrips
> helgrim.com-AutoAssign
> Adding ScripActions...11.12.done.
> Adding ScripConditions...done.
> Adding templates...8.done.
> [root at zimmerdale helgrim.com-AutoAssign]#
> I created an auto-assign scrip on a queue that had a watcher and tried
> creating a ticket.  The ticket creates OK but nobody was auto-assigned to
> it.  I checked the error log and found stuff like this:
> Can't locate RT/Action/.pm in @INC (@INC contains: /opt/rt2/etc /opt/rt2/lib
> /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1
> /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1
> /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0
> /usr/lib/perl5/site_perl . /usr/local/apache/ /usr/local/apache/lib/perl) at
> (eval 626) line 3, <GEN322> line 271.
> Require of RT::Action:: failed.
> Can't locate RT/Action/.pm in @INC (@INC contains: /opt/rt2/etc /opt/rt2/lib
> /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1
> /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1
> /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0
> /usr/lib/perl5/site_perl . /usr/local/apache/ /usr/local/apache/lib/perl) at
> (eval 626) line 3, <GEN322> line 271.
> Hmmm, sounds like the name of the script might be missing somewhere.  It
> seems like it should be looking for "RT/Action/__something__.pm" instead of
> leaving the __something__ blank.
> I went into MySQL and looked around, and things look (as near as I would
> know to recognize) like they should work.  But obviously something's out of
> place.  Anyone got any suggestions for what might be amiss?
> BTW, since there isn't much about this on the website, I would like to
> volunteer to write up a HOWTO for scrip installation, provided I end up
> learning how it's done.
> --
> Kendric Beachey
> _______________________________________________
> rt-users mailing list
> rt-users at lists.fsck.com
> http://lists.fsck.com/mailman/listinfo/rt-users

Feargal Reilly,                        | Communications House, 
Systems Administrator.                 | 1a Lower Pembroke Street,
The CIA - http://www.thecia.ie/        | Dublin 2,
Ph: +353-1-6768230 Fax: +353-1-6767720 | Ireland.

PGP fingerprint: 9EA0 F62E 2345 6062 E522 00F2 31D0 B1B0 D678 96DB

More information about the rt-users mailing list