[rt-users] Problem with new install of RT 3.4.4

Bill Sandiford bill at telnetcommunications.com
Sat Oct 8 23:25:10 EDT 2005

Hi Ruslan:

yes you are correct about the distro Perl

/usr/bin/perl -v    --- gives output of 5.8.0
/usr/local/bin/perl -v   --- gives output of  5.8.7

running 'locate DBI' comes back with no response, same thing for 'locate 
DBI.pm' if that matters

when you are referring to the configure script, what configure script are 
you referring to...for what package.

I installed DBI and every other perl module from cpan, mostly by using 'make 

DBI is version 1.48


----- Original Message ----- 
From: "Ruslan Zakirov" <ruslan.zakirov at gmail.com>
To: "Bill Sandiford" <bill at telnetcommunications.com>
Cc: <rt-users at lists.bestpractical.com>
Sent: Saturday, October 08, 2005 7:18 PM
Subject: Re: [rt-users] Problem with new install of RT 3.4.4

On 10/9/05, Bill Sandiford <bill at telnetcommunications.com> wrote:
> Hello All:
> I'm having a problem with a new install of RT.  I've searched through 
> google
> and the list archive and found other people that have had similar 
> problems,
> but was unable to put my hand on a solution.
> Basically, everything went fine, install of everything was good, there 
> were
> some dependencies that were missing but i fixed that with the make 
> testdeps,
> make fixdeps procedure.
> I added the relevant info to the bottom of my httpd.conf file as per the
> ManualInstallation guide, restarted apache, and when I browse to the page 
> I
> get a 500 Internal server error.
> When I look at apache's error_log I get:
> [Sat Oct  8 16:28:12 2005] [error] Can't locate object method "connect" 
> via
> package "DBI" at
> /usr/local/lib/perl5/site_perl/5.8.7/DBIx/SearchBuilder/Handle.pm line
> 108.\n
> I have verified that DBI is installed, (make testdeps confirmed).  I tried
> removing and re-installing DBI with cpan but there was no change...I still
> get the same error.
Please run 'locate DBI' from shell.
I think you installed perl and also have distro's perl installed. By
default configure script choose default perl in '/usr/bin/perl'. You
have to run
`PERL=/usr/local/bin/perl ./configure`.
Also you use mod_perl then you have to build it against perl you want
to use with RT.

Hope this would help you.

> Here are my versions.
> RT 3.4.4
> uname -a: Linux localhost 2.4.21-4.ELsmp #1 SMP Fri Oct 3 17:52:56 EDT 
> 2003
> i686 i686 i386 GNU/Linux
> mysql 4.1.14
> Apache 1.3.33
> mod_perl 1.29
> perl v5.8.7
> Any help would be appreciated !!!
> Regards,
> Bill
> _______________________________________________
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users
> Be sure to check out the RT Wiki at http://wiki.bestpractical.com
> Buy your copy of our new book, RT Essentials, today!
> Download a free sample chapter from http://rtbook.bestpractical.com

Best regards, Ruslan.

More information about the rt-users mailing list