[rt-users] RT Approvals

Roger Mastrude isd602 at co.santa-cruz.ca.us
Fri Jan 11 15:41:09 EST 2008

Hi. I've been beating my head against the wall trying to get RT
approvals working so we can use it for change management. I'm getting
this error message in file "warn": 


Jan 11 11:40:33 isdws76250 RT: Use of uninitialized value in hash
element at /opt/rt3/lib/RT/Action/CreateTickets.pm line 863.
Jan 11 11:40:33 isdws76250 last message repeated 5 times




I'm using queue "CMs".

A scrip for that queue is: 
Create Approval Ticket
On Create Create Tickets with template Create Approval Ticket

A template for that queue named "Create Approval Ticket" contains: 
===Create-Ticket CreateApprovalTicket
Subject: Approval for {$Tickets{'TOP'}->Subject}
Depended-On-By: TOP
Queue: Approvals
Content: Someone has created a CM ticket. Please review and approve it. 

I tried changing line 1 from "CreatApprovalTicket" to "Create Approval
Ticket" because I wasn't certain how the scrip and ticket tie together.
Same result. 

I'm logged on as Root which is a member of RT Administrators, which has
super-user powers. Queue "Approvals" exists but no tickets have been
autocreated in it.  You can create tickets in it manually. 


I'm using SLES 9 with Apache 1.3.29, Perl and RT 3.6.5. 


Can anyone see something dumb I'm doing? Or just wrong, though smart? 


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20080111/e2548265/attachment.htm>

More information about the rt-users mailing list