[rt-users] Unable to delete or modify dashboards as any user including superuser

Kevin Falcone falcone at bestpractical.com
Mon Aug 9 11:29:36 EDT 2010

On Mon, Aug 09, 2010 at 12:00:10PM +1000, john habermann wrote:
>    Hi
>    I have just noticed I have a problem with editing Dashboards in my RT instance namely I can't
>    do anything with them apart from create them. Once I create them if I click on them I see a
>    page as shown in the attached images, there are simply no options to do anything. I have tried
>    giving the user every dashboard permission available and have even made them Superuser but it
>    makes no difference.
>    The problem appears to have occured when I upgraded from rt 3.8.2 to 3.8.8 as in the older
>    version I see "Basics * Queries * Subscription * Show" link but that has disappeared with the
>    update to 3.8.8. I did install the Timeline module after I upgraded to 3.8.8 so I thought that

When you upgraded, did you run rt-setup-database --action upgrade to
apply the database changes described in UPGRADING?
The internal format of Dashboards changed, and it sounds like you
missed a step.


>    might be the problem as the bug at [1]https://rt.cpan.org/Public/Bug/Display.html?id=39729
>    indicates that it breaks the bulk update but applying that fix does not help the dashboard
>    problem. I tried disabling that module but the problem still persists.
>    Does anyone have any thoughts as to what might be causing this problem?
>    Thank you
> References
>    Visible links
>    1. https://rt.cpan.org/Public/Bug/Display.html?id=39729

> Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> Buy a copy at http://rtbook.bestpractical.com

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 195 bytes
Desc: not available
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20100809/5dfcd7ad/attachment.sig>

More information about the rt-users mailing list