[rt-users] Unable to delete or modify dashboards as any user including superuser

john habermann john.haberman at gmail.com
Thu Aug 12 21:23:42 EDT 2010

Hi Kevin

Thanks for your advice, I am pretty sure that I did apply
the rt-setup-database --action upgrade step when I did the upgrade from
3.8.2 to 3.8.8 but I have tried running it again in case and I get a couple
of warnings like:

[Fri Aug 13 01:06:36 2010] [warning]: Couldn't set SortOrder: That is
already the current value (./etc/upgrade/3.8.8/content:32)

Which makes me think I had already done it. It didn't make any difference to
what I see when I am viewing the dashboards.
I had a look in the rt3.8.8/etc/upgrade folder and I see that dashboards are
mentioned in the 3.8.2 content file so on the off chance that I had missed
that step I ran the upgrades from version 3.8.1 but that has not helped
either. As everything was working fine on my 3.8.2 version I would have
thought that I must have already done that step anyway.

Would their be any other schema changes to the rt database outside those
listed in the etc/upgrade folder?

Thank you

On Tue, Aug 10, 2010 at 1:29 AM, Kevin Falcone <falcone at bestpractical.com>wrote:

> On Mon, Aug 09, 2010 at 12:00:10PM +1000, john habermann wrote:
> >    Hi
> >    I have just noticed I have a problem with editing Dashboards in my RT
> instance namely I can't
> >    do anything with them apart from create them. Once I create them if I
> click on them I see a
> >    page as shown in the attached images, there are simply no options to
> do anything. I have tried
> >    giving the user every dashboard permission available and have even
> made them Superuser but it
> >    makes no difference.
> >    The problem appears to have occured when I upgraded from rt 3.8.2 to
> 3.8.8 as in the older
> >    version I see "Basics * Queries * Subscription * Show" link but that
> has disappeared with the
> >    update to 3.8.8. I did install the Timeline module after I upgraded to
> 3.8.8 so I thought that
> When you upgraded, did you run rt-setup-database --action upgrade to
> apply the database changes described in UPGRADING?
> The internal format of Dashboards changed, and it sounds like you
> missed a step.
> -kevin
> >    might be the problem as the bug at [1]
> https://rt.cpan.org/Public/Bug/Display.html?id=39729
> >    indicates that it breaks the bulk update but applying that fix does
> not help the dashboard
> >    problem. I tried disabling that module but the problem still persists.
> >    Does anyone have any thoughts as to what might be causing this
> problem?
> >    Thank you
> >
> > References
> >
> >    Visible links
> >    1. https://rt.cpan.org/Public/Bug/Display.html?id=39729
> >
> > Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> > Buy a copy at http://rtbook.bestpractical.com
> Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> Buy a copy at http://rtbook.bestpractical.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20100813/cb9da886/attachment.htm>

More information about the rt-users mailing list