[rt-users] Unable to delete or modify dashboards as any user including superuser

john habermann john.haberman at gmail.com
Thu Aug 12 22:16:50 EDT 2010

I have done some more investigating comparing what I see in the 3.8.2
version to the 3.8.8 version and I find that it seems the problem is that
the actions are not changing when you select a dashboard from the list of
dashboards. In the 3.8.8 version when I view the list of Dashboards
rt/Dashboards/index.html the actions are:

Select New

In the 3.8.2 version they are:

Select Dashboard New Dashboard

In the 3.8.8 version when I click on a Dashboard the actions menu lists the
names of the Dashboards:

Home | Tags and Searches | Get Things Done

While in the 3.8.2 version when I select a Dashboard I see:

Basics Queries Subscriptions Show

The urls for when I click on the Dashboard is the same

I see that the rt3/share/html/Dashboards/index.html file has changed from
3.8.2. to 3.8.8 and I tried just using the 3.8.2 index.html version in 3.8.8
but nothing changed. I found that I can edit and delete Dashboards in the
3.8.8 version by manually entering the urls that I can see from the actions
navigation bar in the 3.8.2 version. So if I go
to rt/Dashboards/Modify.html?id=49 I am able to delete a Dashboard from the
3.8.8 version.

Does anyone have any thoughts as to whether this indicates a problem with my
database or something in the html template files?

Thank you

On Tue, Aug 10, 2010 at 1:29 AM, Kevin Falcone <falcone at bestpractical.com>wrote:

> On Mon, Aug 09, 2010 at 12:00:10PM +1000, john habermann wrote:
> >    Hi
> >    I have just noticed I have a problem with editing Dashboards in my RT
> instance namely I can't
> >    do anything with them apart from create them. Once I create them if I
> click on them I see a
> >    page as shown in the attached images, there are simply no options to
> do anything. I have tried
> >    giving the user every dashboard permission available and have even
> made them Superuser but it
> >    makes no difference.
> >    The problem appears to have occured when I upgraded from rt 3.8.2 to
> 3.8.8 as in the older
> >    version I see "Basics * Queries * Subscription * Show" link but that
> has disappeared with the
> >    update to 3.8.8. I did install the Timeline module after I upgraded to
> 3.8.8 so I thought that
> When you upgraded, did you run rt-setup-database --action upgrade to
> apply the database changes described in UPGRADING?
> The internal format of Dashboards changed, and it sounds like you
> missed a step.
> -kevin
> >    might be the problem as the bug at [1]
> https://rt.cpan.org/Public/Bug/Display.html?id=39729
> >    indicates that it breaks the bulk update but applying that fix does
> not help the dashboard
> >    problem. I tried disabling that module but the problem still persists.
> >    Does anyone have any thoughts as to what might be causing this
> problem?
> >    Thank you
> >
> > References
> >
> >    Visible links
> >    1. https://rt.cpan.org/Public/Bug/Display.html?id=39729
> >
> > Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> > Buy a copy at http://rtbook.bestpractical.com
> Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
> Buy a copy at http://rtbook.bestpractical.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20100813/c3836717/attachment.htm>

More information about the rt-users mailing list