[rt-users] RT 3.8.11 and AT 2.0.0b upgrade or uninstall and install fresh

Darin Perusich Darin.Perusich at ctg.com
Thu Jan 12 08:37:51 EST 2012

First, there is an at-users group available at Google Group, link below. It's doesn't see as much traffic as the RT list but it's another resource.

<mailto:at-users at googlegroups.com> 

On 01/11/2012 05:21 PM, Susan McClure wrote: 

	I have a similar question as Kevin Squire on 12/08/2011 till today.
	I tried to install AT 1.2.4b1 on my old system without much success, but
	now I have some AT
	tables, groups etc in my DB (Postgresql)
	I am trying to install AT 2.0.0b from github onto RT 3.8.11 upgraded
	I do not have any AT files/scrips in the RT installation.
	If I try to do a "make initdb" it fails with the same error:

		Now populating database schema.
		DBD::Pg::st execute failed: ERROR:  relation "at_types" already exists
		...returned with error: 65280
		make: *** [initdb] Error 255

I got a similar error when trying to initialize Rt+AT with Postgres. To work around this I needed to remove AT from RT_SiteConfig.pm, uninstalled AT, init RT under Pg, install AT and init the AT tables, which I did  with the below commands. After this I did a mysql to postgres migration but I wouldn't think that should matter as my Pg instance was new. I'm using an RPM package for AT, perl-RTx-AssetTracker, so install/removal is a trivial matter. I can't comment on removing AT if installed from source but you might want to check if there's an 'make uninstall'. For those who are daring you could probably do "find /path/to/rt" -name \*AssetTracker\*" to find all the AT files and then remove manually.

	If I try to do a "make dropdb" to drop the old tables etc, it does not give
	any error, or any output, but neither does it drop any AT tables (like
	at_assets, at_types, at_ips, at_ports).
	I tried a "make realclean" and then tried to install again WITHOUT doing
	an initdb.  I ran the upgrade :

		 /usr/site/rt/sbin/rt-setup-database --dba postgres --prompt-for-dba-password --action schema --datadir etc/upgrade/1.2.4
		and yes, there is NO schema.Pg file (only mysql and SQLite )

I'm running perl-RTx-AssetTracker 2.0.0b2 and the acl.Pg and schema.Pg files do exist. You need to specify the full path to the schema files when running rt-setup-database.

rt-setup-database --action schema --dba rt_user --prompt-for-dba-password --datadir \
rt-setup-database --action acl --dba rt_user --prompt-for-dba-password --datadir \

	How can I do a complete "uninstall" of Asset Tracker, AND remove the
	existing Asset Tracker items from the DB and start over with a fresh
	If you tell me all the tables, templates, AT global group and user
	rights etc, I could
	try to manually drop all the  AT parts from the current DB.

Darin Perusich
Email: Darin.Perusich at ctg.com
Office: 716-888-3690
The information transmitted is intended only for the person or entity to which
it is addressed and may contain confidential and/or privileged material. Any
review, retransmission, dissemination or other use of, or taking of any action
in reliance upon, this information by persons or entities other than the
intended recipient is prohibited. If you are not the intended recipient of this 
message, please contact the sender and delete this material from this computer.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20120112/c789451b/attachment.htm>

More information about the rt-users mailing list