[rt-users] RT 4.2.1 - Weird issue with HTML comments/correspondense - RT always registers plain text with HTML tags

Bart bart at pleh.info
Wed Dec 11 03:20:42 EST 2013

Hi again,

After some testing/searching I still haven't found the exact cause for this

The only workaround that I could find was disabling the Rich Text editor by
default or manually, after that everything worked as intended. But, without
HTML / text formatting....

In the end I've reinstalled version 4.2.0 on top of version 4.2.1 in the
test environment (without applying the DB patches, so the DB is still up to
the level of version 4.2.1). After applying the 4.2.0 installation RT shows
(as intended) itself as version 4.2.0 and this issue with the rich text
editor is gone and everything works immediatly as before.

So for production I also went back to version 4.2.0 without applying the
database patches....

Overall, this downgrade fixed my problem, but I still have no clue as to
where I should look for the problem. When I summarize what I've found so

   - Issue exists only in version 4.2.1, version 4.2.0 works just fine.
   - Something specific for my rich text editor, I have a custom config in
   this location:
      - /opt/rt4/local/static/RichText/config.js
      - (though, removing this doesn't fix the problem, even with all
      defaults it doesn't work)
   - At first I assumed this issue was with the RichText editor itself, so
   I copied the RichText editor from version 4.2.0 to the 4.2.1 installation.
   This however had no effect (made no difference):
      - I've copied/replaced this directory: /opt/rt4/share/static/RichText
      - For as far as I can verify this problem isn\t with the templates.
   The problem exists with both plaintext and html for the correspondense
   template. Also, the same templates work just fine under version 4.2.0.
   - The system and apache logs don't tell me anything either, I can't find
   any errors in there that could even remotely indicate a problem...

So at this point I have no clue as where to look further, I would assume
somewhere in the code that handles the comment/correspondense but that's
not exactly my cup of tea...

Any insight would be nice! I really would like to solve this.

But for now I'm sticking with version 4.2.0. Though I do hope that I can
get version 4.2.1 to work, or maybe version 4.2.2 when it becomes available
(hopefully that version doesn't have the same issue)

Bart G.

2013/12/10 Bart <bart at pleh.info>

> Hi again,
> Even though I've tested it all, I've found a new piece of
> information/cause:
> - Initially I've done testing with RT 4.2.0 on a copy of my production
> installation, all tests with this version went perfect
> - After upgrading to version 4.2.1 I have this same issue in my testing
> environment, seems that I didn't test properly after doing this update or
> atleast I didnt look at this specific case!
> So basically, this worked just fine with version 4.2.0 and somehow got
> broken in version 4.2.1.
> Is there something I need to configure / install / patch before this
> problem is fixed within version 4.2.0 ?
> Thanks in advance!
> 2013/12/10 Bart <bart at pleh.info>
>> Hi,
>> As the subject states, when I place a comment or correspondence to a
>> ticket it registers it all as plain text with HTML tags.
>> E.g. Hello world in bold would look like this in the ticket history:
>> <br /> <strong>Hello world</strong><br />  
>> On top of that, outgoing mails also look like this....
>> My first thought would be that the templates we're broken since the
>> update, but after updating the correspondense template for HTML (which it
>> already was, but I copied the example HTML correspondense template just in
>> case). Here's how the template looks:
>> RT-Attach-Message: yes
>> Content-Type: text/html
>> {$Transaction->Content( Type => "text/html")}
>> But, even with this template it keeps regisgtering HTML code as plain
>> text and sending out the same code as outgoing mails.
>> I can'f find any errors regarding this within the system/apache logs, so
>> I'm kinde lost at where to begin with fixing this problem. Especially since
>> I had a testing environment (copy of production) which seemed to work just
>> fine.....
>> So does anyone know where I should start for fixing this? I could imagine
>> that some perl module got broken, but I really don't know which one I
>> should reinstall or update...
>> Thanks in advance!
>> --
>> Bart G.
> --
> Bart G.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20131211/fc94be5a/attachment.htm>

More information about the rt-users mailing list