[rt-users] Trying to get RT4.2.2 to use mysql and not sqllite3

john boris jborissr at gmail.com
Tue Feb 11 15:38:40 EST 2014

\I finally got things moving today. I had tried to do the install from the
repositories which failed and thought I removed it when I tried to install
from the source. So I went in and did a full removal of request-tracker4
through apt-get purge --ato-remove request-tracker4. I then retraced my
steps in the install from source and after a failed install I found that
the database had been installed somehow but not correct so I did a make
dropdb and initialized the database. I got the opening page but no graphics
so I figured there was something wrong. So I did some more reading of the
errors and saw I did not configure the RT_SiteConfig.pm correctly. I fixed
that (commented out the WebPath variable) and got it up and running.

Thanks for all of the help. I ow just have to start building my queues but
this time with less queues than my old install.

The next hurdle will be getting rt-mailgate operating.

On Mon, Feb 10, 2014 at 1:37 PM, Kevin Falcone <falcone at bestpractical.com>wrote:

> On Fri, Feb 07, 2014 at 12:30:45PM -0500, john boris wrote:
> >    Kevin,
> >    Thanks for the reply. I reran the script and selected mysql (which I
> did originally) it had an
> >    error at the end and I had a choice to retry, abort, retry (skip
> questions) so I said retry
> >    and it asked me the questions again and I answered as before and the
> script ended without an
> >    error. I went into Mysql with phpmyadmin and the database was created
> by when I go to the web
> >    address I now get
> >
> >      * Config file /etc/request-tracker4/RT_SiteConfig.pm is locked
> >
> >    I checked all of my windows and I don't have it opened anywhere.
> >    I restarted the server just in case but I still get the message.
> You would need to show the errors you get and show your RT log errors.
> The RT_SiteConfig.pm being locked implies you ran but failed to
> complete the Web Installer (or that the Debian installer uses this
> behavior too).
> You could manually change permissions on that file, but I'd want to
> know how it got to that state.
> -kevin

John J. Boris, Sr.
Online Services
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20140211/b22056b8/attachment.htm>

More information about the rt-users mailing list