[rt-users] Fwd: Request tracker

Gerald Jimenez gejimene at gmail.com
Thu Nov 19 12:31:04 EST 2015


I installed a fresh version of apache on a new centos 7, after the error I
manually  installed the  Data::UUID module from yum and after that from
source but I got the same error.

This is the rt.log using debug:

Tue Nov 10 12:56:53.844353 2015] [core:notice] [pid 5852] AH00094: Command
line: '/usr/sbin/httpd -D FOREGROUND'
[5886] [Tue Nov 10 17:57:03 2015] [critical]: Can't locate loadable object
for module Data::UUID in @INC (@INC contains: /opt/rt4/sbin/../local/lib
/opt/rt4/sbin/../lib /usr/local/lib64/perl5 /usr/local/share/perl5
/usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5
/usr/share/perl5 .) at /usr/local/lib64/perl5/Data/GUID.pm line 10.
Compilation failed in require at /usr/local/lib64/perl5/Data/GUID.pm line
10.
BEGIN failed--compilation aborted at /usr/local/lib64/perl5/Data/GUID.pm
line 10.



On Thu, Nov 19, 2015 at 12:20 PM, Parish, Brent <bparish at cognex.com> wrote:

> I don't have any super advice here, just throwing out some ideas in case
> it helps.
>
> I don't see Data::UUID in the Perl requirements for RT?
> It looks instead to be something needed by Apache, for ModPerl or FCGI?
>
> Tough to say without being on the system, but from what I understand it's
> not missing Data::UUID itself, but rather an object associated with it
> (e.g. shared object, etc)?
> That can happen if you copied over any of the libs instead of installing
> them?
>
> I wonder what might happen if you do a 'forced' full re-install of
> Data::UUID?
> Or maybe there are some leftover pointers to an older version of the
> shared objects?
> e.g. If Apache was copied over and not upgraded, etc
>
> Did you get that error from the Apache logs and are they cranked up to
> debug level?
> Are there other error lines nearby in the log(s) that might have more
> details?
>
> - Brent
>
>
> -----Original Message-----
> From: rt-users [mailto:rt-users-bounces at lists.bestpractical.com] On
> Behalf Of Matt Zagrabelny
> Sent: Monday, November 16, 2015 11:39 AM
> To: Gerald Jimenez
> Cc: rt-users
> Subject: Re: [rt-users] Fwd: Request tracker
>
> On Mon, Nov 16, 2015 at 10:36 AM, Gerald Jimenez <gejimene at gmail.com>
> wrote:
> >
> > Hi,
> >
> > I have request tracker installed on a centos 6 server but now I need
> > to update my server to centos 7.
> > I have tried to install request tracker 4.2 to my centos 7 server but
> > after sucessfully finished the installation the web page of rt doesnt
> > load and I got this error "Can't locate loadable object for module
> Data::UUID in @INC".
>
> Do you have that module installed?
>
> -m
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20151119/899961f9/attachment.html>


More information about the rt-users mailing list