[svk-devel] Error on 'svk sync -s'

Rolf Schäuble mailinglists at rschaeuble.de
Tue Oct 24 18:05:09 EDT 2006


I did some more testing, which shows that the error is most likely  
not caused by the content of the change log.
I tried two things:

1. I tried to sync another repository hosted by sourceforge (https:// 
svn.sourceforge.net/svnroot/gaim), using the same steps as in my  
first email. This returns the same error about REPORT failing.
2. I routed SVK over an stunnel, so I could connect via localhost,  
which allowed me to sniff the http conversation with ethereal. SVK  
sends a REPORT request with the following parameters (encoded in XML):
start revision: -1
end revision: -1
limit: 1

The server answers with a "200 ok".

Does anyone here understand what the problem is? I certainly don't.  
Is this a bug in SVK, or in SVN?
Basically, what could I do to come closer to a solution for this  


Am 23.10.2006 um 22:43 schrieb Rolf Schäuble:

> Hi,
> I'm a new svk user, and so far I love this software.
> Yesterday I was trying to mirror a repository hosted by  
> sourceforge. When using "svk sync" (to fully sync), everything was  
> fine. However, when I tried to sync with the "-s" option, I ran  
> into problems.
> On two of my machines, I get the following error:
> RA layer request failed: REPORT request failed on '/svnroot/ 
> clucene/!svn/bc/2347/trunk': REPORT of '/svnroot/clucene/!svn/bc/ 
> 2347/trunk': 200 OK (https://svn.sourceforge.net)
> Here are the steps to reproduce:
> svk depotmap /clucene <path_to_repository>
> svk mirror https://svn.sourceforge.net/svnroot/clucene/trunk / 
> clucene/trunk (anyone can try this, no authentication required)
> svk sync -s 2300 /clucene/trunk
> These are the specs of the two machines I got the error on:
> 1. Linux, Fedora Core 5, svk 1.08, svn 1.3.2
> 2. Mac OS X, using DarwinPorts (now Macports), svk 1.08, svn 1.4.0
> Today, at work, I tried the same thing, but on a Windows XP SP2  
> box. svk version was 1.08, svn was (I think) 1.3.x.
> On that configuration, it worked!
> Now I have searched the internet carefully, and found a few  
> postings that indicate that an invalid character in a log message  
> might cause this problem. However, looking at the log of that  
> repository, I can't find the culprit. Is there any easy way to find  
> that entry, so I can contact therepository administrator? Can I  
> reproduce this error with an svn command?
> I would appreciate any help with this problem
> Thanks
> Rolf
> _______________________________________________
> svk-devel mailing list
> svk-devel at bestpractical.com
> http://lists.bestpractical.com/cgi-bin/mailman/listinfo/svk-devel

More information about the svk-devel mailing list