[svk-devel] 501 error doing a remote to remote svk cp after upgrade to 2.0

Huw huw.nichols at gmail.com
Sun Jan 7 13:24:44 EST 2007


Was wondering, hoping, someone could help me out pls.

I have just upgraded to 2.0 and first thing I did was to try and
create a remote branch thus:

svk cp //client/remote/trunk //client/remote/branches/2.5

And I get the following error back:

"RA layer request failed: REPORT request failed on
'http://solidsteam.tk/svn/ria_spreadex': REPORT of
'http://solidsteam.tk/svn/ria_spreadex': 501 Method Not Implemented
(http://solidsteam.tk) at
/usr/local/svn/perl/SVK/Mirror/Backend/SVNRa.pm line 310."

The //client/remote/trunk mirrors my svn repo hosted on textdrive

Earlier commands of the same form but to create tags worked just fine.

Strange thing is that is I do an svk list //client/remote/branches

I see nothing but if I browse to the repo all seems to be in order,
have not tried using this branch yet as I am wary of the error and
would like to understand it and its implications first if possible.

I am using a macbook for client with latest 2.0 svk installed, local
svn client is V 1.4.2, textdrive svn server reports V 1.2.x

Does anyone have some comforting words that all is going to be ok or
better yet how to fix it and see the results in svk list etc. please ?



More information about the svk-devel mailing list