[rt-users] Using the 'rt' commandline tool from a different machine gives me a 405 error

Landon landonstewart at gmail.com
Fri Apr 19 17:41:20 EDT 2013

I took the command line tool from bin/rt of the rt-3.8.15 download from
bestpractical's website which is the same version used on the server.  The
full URL of the rt installation does not include a path in the URL since
it's installed in the root (/) of that site.  It is however using https and
not http.  I've tried adding a trailing / to the server specified and
without in the .rtrc file.

Using that commandline tool and with my credentials and server configured
in .rtrc I get an error message after approximately 1 minute:

$ time rt ls -o -Created -t ticket "Queue = 'General' AND Status !=
'resolved' AND Created < '1 hours ago'" -f
rt: Server error: Not Allowed (405)

real 1m0.718s
user 0m0.175s
sys 0m0.028s

When using the Web UI I'm granted rights and have no issues.  Per the
information at http://requesttracker.wikia.com/wiki/CLI I've tried setting
the RTDEBUG env variable to a value of "1" hoping to get more detail than
the output above.  Can anyone tell me what I might try next to figure out
why it's not working as expected?

Thanks for reading!

Landon Stewart <LandonStewart at Gmail.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20130419/b791edd5/attachment.htm>

More information about the rt-users mailing list