[rt-users] Quicksearch not displaying queues

Sam Florida sam.florida at gmail.com
Tue Nov 18 13:29:13 EST 2014


Hello all,

I'm receiving an error after migrating from 4.0.8 to a new server with a
4.2.9 install:
[error]: Can't call method "Name" on an undefined value at
/opt/rt4/share/html/Elements/QueueSummaryByLifecycle line 131.

Restoring the 4.0.8 database to the new installation appeared to be
successful, yet Quicksearch failed to display a queue listing.  The
aforementioned error appears to be the culprit:
Stack:
  [/opt/rt4/share/html/Elements/QueueSummaryByLifecycle:131]
  [/opt/rt4/share/html/Elements/Quicksearch:58]
  [/opt/rt4/share/html/Widgets/TitleBox:56]
  [/opt/rt4/share/html/Elements/Quicksearch:58]
  [/opt/rt4/share/html/Elements/MyRT:95]
  [/opt/rt4/share/html/index.html:78]
  [/opt/rt4/sbin/../lib/RT/Interface/Web.pm:681]
  [/opt/rt4/sbin/../lib/RT/Interface/Web.pm:369]
  [/opt/rt4/share/html/autohandler:53]
(/opt/rt4/sbin/../lib/RT/Interface/Web/Handler.pm:208)

I then wiped the 4.2.9 installation, installed a new 4.0.8 to import the
database, and then attempted an upgrade to 4.2.9.  The upgrade went
smoothly, and the upgrade history appears to display every version
change. However, once having reached 4.2.9, I face the same error again.

The previous 4.0.8 installation had RTIR installed, and both installations
use postgres.  The queues table appears to be correctly populated with name
information, with all queues (aside from the disabled RTIR queues) having
default Lifecycles.

 I'm likely frustrated enough to be missing something obvious, so any
assistance would be greatly appreciated.

Thanks much,
Sam
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20141118/580e4feb/attachment.html>


More information about the rt-users mailing list