[rt-users] RT eats table-tags in html-emails

Guadagnino Cristiano guadagnino.cristiano at creval.it
Mon Jan 19 05:24:48 EST 2015


Alex,
you were right: HTML::Gumbo installation failed on my box, but I did not notice it initially.

Trying to reinstall HTML::Gumbo now, I noticed that 'libtoolize' was missing, so I installed it.
Unfortunately it fails again because it wants autoconf >= v2.65, and there is only v2.63 in CentOS repository.

I'll have to wait until CentOS updates the repos.

Thank you!

Bye
Cris

________________________________
Da: Alex Peters <alex at peters.net><mailto:alex at peters.net>
Inviato: Mon Jan 19 2015 09:06:29 GMT+0100 (CET)
A: Guadagnino Cristiano <guadagnino.cristiano at creval.it><mailto:guadagnino.cristiano at creval.it>
Cc: "rt-users at lists.bestpractical.com"<mailto:rt-users at lists.bestpractical.com> <rt-users at lists.bestpractical.com><mailto:rt-users at lists.bestpractical.com>
Oggetto: Re: [rt-users] RT eats table-tags in html-emails
HTML tables are mostly displaying as expected on my installation (ignoring missing images and CSS).  I'm running v4.2.7 though; I guess it's possible that a regression has occurred in a later version.

There are no other relevant settings in my RT_SiteConfig.pm file, and I'm 90% sure that I didn't add any special flags when I ran the "configure" script.

Looking at the code, HTML::Gumbo would be ignored if it failed to install properly for some reason.  Are you seeing anything interesting in RT's debug logs?  I remember having to grab a very fresh HTML::Gumbo version because of some installation issue I encountered with an older (but still somewhat recent) one.

Lastly, you've probably already done this, but for the sake of documentation, RT would need to be restarted after the installation of this module.


Cristiano Guadagnino

Servizio Sistemi Dipartimentali, Periferici e DB
_______________________________
Bankadati Servizi Informatici Soc.Cons.P.A.
Gruppo bancario Credito Valtellinese
VIA TRENTO, 22 - 23100 SONDRIO
tel +39 0342522172  - fax +39 0342522997
guadagnino.cristiano at creval.it
www.creval.it<http://www.creval.it>

Il presente messaggio non è di natura personale ma inviato per esigenze lavorative; l’eventuale messaggio di risposta potrà essere conosciuto anche da altri soggetti diversi dall’originatore di questo messaggio per dette esigenze o per controllo aziendale. Questo messaggio, corredato dei relativi allegati, contiene informazioni da considerarsi strettamente riservate, ed è destinato esclusivamente al destinatario sopra indicato, il quale è l'unico autorizzato ad usarlo, copiarlo e, sotto la propria responsabilità, diffonderlo. Chiunque ricevesse questo messaggio per errore o comunque lo leggesse senza esserne legittimato è avvertito che trattenerlo, copiarlo, divulgarlo, distribuirlo a persone diverse dal destinatario è severamente proibito, ed è pregato di rinviarlo immediatamente al mittente distruggendone l'originale.

On 19 January 2015 at 18:56, Guadagnino Cristiano <guadagnino.cristiano at creval.it<mailto:guadagnino.cristiano at creval.it>> wrote:
I have both already set. Is it working in your system?
Did you need to add something to the config command line?


________________________________
Da: Alex Peters <alex at peters.net><mailto:alex at peters.net>
Inviato: Mon Jan 19 2015 08:48:45 GMT+0100 (CET)
A: rt-users at lists.bestpractical.com<mailto:rt-users at lists.bestpractical.com> <rt-users at lists.bestpractical.com><mailto:rt-users at lists.bestpractical.com>
Cc: Guadagnino Cristiano <guadagnino.cristiano at creval.it><mailto:guadagnino.cristiano at creval.it>
Oggetto: Re: [rt-users] RT eats table-tags in html-emails
Looking at the RT_Config documentation, I think you might need to enable the $TrustHTMLAttachments setting.  I know I've enabled that in my local installation.

You might also need to increase the $MaxInlineBody setting from its default of 12,000 bytes (or set it to 0 to disable size limiting altogether), since things with HTML tables in my experience tend to frequently exceed that limit.

On 19 January 2015 at 18:41, Guadagnino Cristiano <guadagnino.cristiano at creval.it<mailto:guadagnino.cristiano at creval.it>> wrote:
I did this while upgrading to 4.2.9 but nothing changed in the dispplay of html tables.
Is there something more that needs to be done?
IIRC this is not very well documented... just a note among the release notes.

T.I.A.

Cris


________________________________
Da: Alex Peters <alex at peters.net><mailto:alex at peters.net>
Inviato: Sat Jan 17 2015 01:09:38 GMT+0100 (CET)
A: ktm at rice.edu<mailto:ktm at rice.edu> <ktm at rice.edu><mailto:ktm at rice.edu>, vinz <vinzenz.sinapius at tracetronic.de><mailto:vinzenz.sinapius at tracetronic.de>
Cc: <rt-users at lists.bestpractical.com><mailto:rt-users at lists.bestpractical.com>
Oggetto: Re: [rt-users] RT eats table-tags in html-emails

Another solution in recent versions of RT is to install the HTML::Gumbo module from CPAN, which should automatically enable correct display of all HTML in tickets without any coding.






--
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20150119/db0e8abd/attachment.html>


More information about the rt-users mailing list