[rt-users] rt-crontool returns "No recipients found. Not sending."

Alex Hall ahall at autodist.com
Thu Dec 22 16:17:33 EST 2016

Hi all,
Further to my rt-crontool question about notifying ticket owners of
untouched tickets, I've made a bit of progress in that I'm getting a new
error. I tried adding
--transaction first
to the crontool call, and that seemed to do something. Now, I'm getting an
error similar to:

[17710] [Thu Dec 22 21:04:01 2016] [info]: <
rt-4.4.1-17710-1482440641-776.656-0-1 at example.com> No recipients found. Not
sending. (/opt/rt4/bin/../lib/RT/Interface/Email.pm:806)

My actions are:

--action RT::Action::Notify
--action-arg RT::Action::NotifyOwnerOrAdminCc
(also tried)
--action-arg owner

I don't know where this address is coming from, or what it means, but
clearly some address is being found. Why would it say there are no
recipients found, then? The ticket requestor is the same as the owner,
because we have our RT set up to make that happen on ticket creation, if
that will be a problem. What might I be missing? I'm so close to having
this working! RT4.4.1, Debian 8. Thanks!

Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20161222/2c4340a0/attachment.htm>

More information about the rt-users mailing list