[rt-users] Enabling extensions in RT4.2.8?

Alex Hall ahall at autodist.com
Fri Sep 23 08:07:23 EDT 2016


Strange... I get an exit code of 255 on my FCGI server with the extension
enabled. If I comment out the lines in my Plugins file and update
siteconfig, I get no error code, but the server immediately quits silently.
There's nothing in any log to tell me what's going on, at least that I can
find. RT was working perfectly until I installed and enabled the
PriorityAsString extension, though I don't know if the install itself or
the attempt to modify my settings did it.

Is there a way to remove an extension so I can start over? I installed
using the commands on its homepage, not CPAN, so I don't know if that
caused a problem. I don't see any uninstall/remove commands on the plugin's
page, but maybe there's a standard way using Perl commands that I don't
know?

On Thu, Sep 22, 2016 at 3:25 PM, Alex Hall <ahall at autodist.com> wrote:

> Thanks for the response. Any thoughts on why I'm suddenly now getting
> "child exited with code 255" when I run my usual spawn-fcgi command (using
> this with Nginx)? I've never seen this error before, and can't find much of
> anything online about it. I'm not sure what's going on, but this started
> after I made 70-plugins, added the lines to it, ran update-rt-siteconfig-4,
> and deleted /var/cache/request-tracker4/mason_data/obj.
>
> I said I added lines to the file. After the line to enable the plugin, I
> had to put in the priorities I want, according to the extension's homepage:
> Plugins('RT::Extension::PriorityAsString');
> Set(%PriorityAsString, (None => 0, Low => 10, Medium => 20, High => 30,
> Critical => 40));
>
> What little I found said that 255 is often caused by permission problems,
> so I ran chown www-data on the mason_data directory to be sure the process
> could re-create the obj/ directory. I can't think what else to try. My log
> file has nothing in it, /var/log/messages has nothing helpful, and my Nginx
> file is of no use, as expected for this kind of problem.
>
> I didn't realize I could make my own files in the RT_SiteConfig.d
> directory, I thought I had to use the existing ones. That's handy.
>
> On Thu, Sep 22, 2016 at 2:04 PM, Matt Zagrabelny <mzagrabe at d.umn.edu>
> wrote:
>
>> Hi Alex,
>>
>> On Thu, Sep 22, 2016 at 12:50 PM, Alex Hall <ahall at autodist.com> wrote:
>> > Hi all,
>> > I can't seem to find the instructions for enabling extensions in 4.2.8.
>> I've
>> > found some for 3.x, but I thought I read somewhere that the syntax is a
>> bit
>> > different for 4.x. I know I add something to 50-debconf, but I'm not
>> sure
>> > exactly what.
>>
>> You can add the configuration "code" to any file in
>> /etc/request-tracker4/RT_SiteConfig.d.
>>
>> The configuration "code" is:
>>
>> Plugin('RT::Extension::PriorityAsString');
>>
>> So you might have a file like:
>>
>> /etc/request-tracker4/RT_SiteConfig.d/70-priority-as-string
>>
>> with the aforementioned Plugin line.
>>
>> Then run your:
>>
>> update-rt-siteconfig-4
>>
>> Then clean your mason cache:
>>
>> sudo find /var/cache/request-tracker4/mason_data/obj -delete
>>
>> and restart your webserver
>>
>> -m
>>
>
>
>
> --
> Alex Hall
> Automatic Distributors, IT department
> ahall at autodist.com
>



-- 
Alex Hall
Automatic Distributors, IT department
ahall at autodist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.bestpractical.com/pipermail/rt-users/attachments/20160923/2435ae01/attachment.html>


More information about the rt-users mailing list